2

I managed to get an authentication through ldap on my SLES 12 machine, but I can't set a certain group as sudoers. My suders entry looks as follows:

%LNX-ADMIN-vibe3 ALL=(ALL) NOPASSWD:ALL

But all I get when trying sudo su is

*Username* is not in the sudoers file.  This incident will be reported.

I tried set the nsswitch.conf to sudoers: files sss but then the error message changes:

*Username* is not allowed to run sudo on *Servername*.  This incident will be reported.

So I also tried adding following attributes to my LDAP Group

cn=LNX-ACCESS-vibe3

object Class    sudoRole 
sudeCommand     ALL
sudoHost        ALL
sudo user       %LNX-ACCESS-vibe3

But still no effect. I think the nsswitch.conf is the one controlling the location from with the sudoers file is getting his information. So currently its set to ldap so it accesses the ldap.conf file. If any further information about the LDAP tree is required, please ask.

  • try enclosing in quote "%LNX-ADMIN-vide3" – Archemar Sep 16 '16 at 9:38
  • unfortunatly that didnt help. tried it with bith nsswitch options – Meerkat Sep 16 '16 at 9:52
  • is LNX-ACCESS-vibe3 an LDAP group? what does grep ^group /etc/nsswitch.conf and getent group LNX-ACCESS-vibe3 show? – MikeA Sep 21 '16 at 19:03
  • Yes it is. and here are my outputs: grep ^group /etc/nsswitch.conf group: files sss group_compat: files and no output with getent group LNX-ACCESS-vibe3 – Meerkat Sep 22 '16 at 8:27
  • I assume that the user you are using is in that group? Also, changes to groups requires you to log out and back in. – John Leuenhagen Sep 28 '16 at 0:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.