0

First thanks of you all. many times I've got answer here.

I'm an ordinary linux user. For 2 years I had win8 and then win10 with Linux Mint 17 & 17.2 together. There was any problem to boot by Linux Mint boot loader for both.

I have got an Acer laptop, i7, HDD 1tra, VGA 2G, RAM 16G. And installed Linux in different partition of Windows. Indeed from end of Hard.

I decided to install Debian Jessie instead of mint so downloaded "debian-8.5.0-amd64-DVD-1.iso" from site & made a bootable CD by it, but had to install twice it.

In first installing, for where Master Boot Recorder should be installed, there were two choices: 1) manually 2) ata ...

I checked the first choice (manually) but decided to back & marked second choice (ata...) because thought this is complete of hard & is better choice. after boot I noticed there isn't Windows loader in boot text. I search a little and didn't get any response but grasp that Windows loader partition is first one of Hard.

So again installed Jessie & this time chose /dev/sda1 for MBR. Sadly the result was the same. In new search encounter this command: "update-grub" , a hope light! So manage "source.list" for repositories & did these first commands:

sudo apt-get update

sudo aptitude update

sudo apt-get install build-essential

sudo apt-get install linux-headers-$(uname -r)

and hopefully typed "update-grub" & result was:

Generating grub configuration file ...

Found background image: /usr/share/images/desktop-base/desktop-grub.png 

Found linux image: /boot/vmlinuz-3.16.0-4-amd64 

Found initrd image: /boot/initrd.img-3.16.0-4-amd64 

Found Windows Recovery Environment (loader) on /dev/sda1 

done

Really got happy and became better when I saw "Windows Recovery Environment (loader) (on /dev/sda1)" after reboot, but unfortunately does not work!!

When I choose it by arrow keys & Enter, the page return back to itself & nothing happens. It just boots Debian.

I'll be so thankful to to listen your guides.

  • Type the result of mount command. EFI partition must be mounted to get grub working. Are your machine EFI or BIOS based? Maybe you have installed the Debian in BIOS mode, but Windows are running in EFI boot, so you cant boot each other. If this is the case you must install grub-efi package... and configure your bios for the EFI mode ,disabling the legacy mode. – Luciano Andress Martini Sep 15 '16 at 20:55
  • your question is missing at least the detail about your hardware using UEFI or not – AnonymousLurker Apr 29 '18 at 20:14
1

To disable os-prober add the following line to sudo gedit /etc/default/grub:

GRUB_DISABLE_OS_PROBER=true

Discover the UUID of the partition containing the Windows boot loader

sudo blkid /dev/sda1

The output will be something like this:

/dev/sda1: LABEL="System Reserved" UUID="1D584C40586B2873" TYPE="ntfs" PARTUUID="adc19fb9-33"

Use the UUID value to create a custom menu entry at the end of the sudo gedit /etc/grub.d/40_custom

menuentry "Windows 10" --class windows --class os {
   insmod ntfs
   search --no-floppy --set=root --fs-uuid 1D584C40586B2873
   ntldr /bootmgr
}

Update grub by:

update-grub

now restart your system & see the "Win 10" in the Grub.

this link was useful

https://wiki.debian.org/DualBoot/Windows10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.