0

I am wondering is the port correctly setup in my Suse linux if it is showing this? I need to access port 30015 from another host, but at present it is able to ping the host but not able to connect to the port. enter image description here

enter image description here

enter image description here

  • 21229 pts/0 S+ 0:00 grep 30015 That is the output – JackyBoi Sep 15 '16 at 7:44
  • Actually the port is not for FTP purposes, it is a required port by an application that I am installing on windows server and I installed the database on suse. – JackyBoi Sep 15 '16 at 8:39
  • Login to soldb and do either of the following telnet soldb 30015 or nc -v soldb 30015 – Zama Ques Sep 15 '16 at 9:10
  • Also this netstat -tlnp | grep 30015 – Zama Ques Sep 15 '16 at 9:10
2

From the netstat screenshot you shared , it seems Port 30015 is listening in TCP mode. Now to check the connectivity , you can use telnet or nc command

    telnet  <hostname>  30015 
           or 
    nc -v <hostname> 30015

For example , I am checking for Port 22

     nc -v localhost 22
     Connection to localhost 22 port [tcp/ssh] succeeded!
     SSH-2.0-OpenSSH_5.3

If you are getting "Connection refused" message , check for firewall on destination server.

You can use below command to check firewall rules

       iptables -L -n (as root)

If iptables is blocking the connection , disable iptables using below command or add new rules to allow SSH

Disabling Iptables

  service iptables stop ; chkconfig iptables off

Adding rules to allow SSH

 -A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
  • It is worth noting that OpenSuse has a firewall/iptables frontend. If it is enabled, iptables should not be used directly for modifying rules as the firewall will overwrite changes. – Paul Nordin Sep 15 '16 at 6:28
  • When i telnet from the windows, I am unable to .. please see my original question updated with more screenshots. – JackyBoi Sep 15 '16 at 8:27
  • I just replied as comments to your original description – Zama Ques Sep 15 '16 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.