1

I installed Linux Mint after Windows 8 (OEM install) on an ASUS UX32LN. Worked fine, just that I never checked if Win8 boots ok again. Then one time I ran out of battery power (usually I used Suspend). Afterwards, Linux would not wake from Suspend, I had to reset it with the power button for 20s.

Then not even that worked, I had to open up, remove the battery, then it would start. Then I tried to boot Win8 again, and it froze. Could not boot it with the battery trick or otherwise. I took the SSD into another PC, it booted windows directly (skipped grub somehow). So I thought my laptop has some hardware issue. I wanted to prepare it for service (by doing a reinstall of windows). I started the reinstall on this other pc but shut it down on the license agreement page. I booted Linux Mint from a USB stick, deleted my Linux Mint from this drive (and the swap partition) but left Windows in place. Then I placed it back in the laptop. Now it managed to boot again (3 times in a row) but it goes to grub command line immediately (ignores any F2/F10/Del to enter BIOS, ignores plugged in USB stick with Linux Mint) where it freezes.

I tend to think there is nothing physically wrong with it just I messed up the laptop somehow. Please don't ask me to remove the SSd anymore from the laptop I'm so sick of unscrewing and screwing those tiny screws for the milionth time... Hope someone can help me. What should I do... I just have another Linux pc, no more Win8 machines to make a recovery disk (not that I think it would boot it).

0

Your biggest problem seems to be that you cannot boot anything (like "live CD", Windows Repair, etc.) If you could, you could inspect your hard drive, backup your stuff, etc., repair the boot.

The simplest approach would be to figure how to get into your BIOS. Make sure you have tried all the possibilities carefully. If you can get into the BIOS, you can boot from recovery or repair media.

But if that really doesn't work: Grub is a 2 stage loader. By deleting your linux partition, you have deleted the second stage. But, the first stage may be almost as capable as your BIOS in selecting a device to boot from (like your Linux Mint USB stick).

Here is what to try and expect. At the grub> prompt, type ls. If this responds with data , you can try to use grub to select a device to "chainload". This might be a CD, DVD, or USB stick which is bootable. You should do a little research before trying this. But here are a few hints:

grub> set pager=1
grub> help
grub> ls

Once you have identified the device or partition you want to boot

set root=(hd1)
chainloader +1
boot

(hd1) is a placeholder for the name of the device you want to boot from. You will need to figure out what this should be for your system and recovery device, using ls.

This will probably work for recovery media (live CD, live USB, etc) but may not work to boot a partition on your SSD, like (hd0, msdos1).

Final comments:

If you remove the battery, leave it out for 10 minutes, before putting it back in. This will increase the chances that the BIOS will forget whatever was preventing it from behaving normally (for example, when you initially had a failed suspend).

If you do boot something, try to do a normal shutdown. This may also clear the BIOS of any flags which are confusing it.

  • I can't type anything at the grub prompt...the machine freezes when it reaches it. I just see it but no key I press appears and the blinking cursor is permanently on. – Justincase Sep 15 '16 at 17:48
  • So sorry to hear. Is is possible that your keyboard is not working? This would explain why you cannot get into the BIOS, as well as why you cannot type anything at the grub prompt. You could try an external USB keyboard. – CliffC Sep 16 '16 at 0:34
0

I find solution for you from: Accessing UEFI Firmware on a computer that shipped with Windows 8

  1. Press Windows Key + C  to access the Windows 8 Charms bar
  2. Click Power & choose Restart while holding down the Shift Key
  3. In the Boot Options menu choose Troubleshoot
  4. In the Advanced Options menu choose UEFI Firmware Settings
  5. Make changes

Delete windows efi boot item from bios boot menu. If possible add bios setup to efi boot order menu. Windows can't boot Linux, but Linux can boot Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.