1

Running Kali, recently got TL-WN772N adapter, for some reason at the start of Wifite it gives me the choice of which interface to select, it seems that enables the monitor mode then goes straight back to selecting an interface. I've tried fluxion and it I selected wlan1 (TL-WN772N) and it worked perfectly.

I've tried disabling wlan0 by adding iface wlan0 inet manual to /etc/network/interfaces also ifconfig wlan0 down.

I am fairly new to Linux, any help would be greatly appreciated.

 .;'                     `;,    
 .;'  ,;'             `;,  `;,   WiFite v2 (r87)
.;'  ,;'  ,;'     `;,  `;,  `;,  
::   ::   :   ( )   :   ::   ::  automated wireless auditor
':.  ':.  ':. /_\ ,:'  ,:'  ,:'  
 ':.  ':.    /___\    ,:'  ,:'   designed for Linux
  ':.       /_____\      ,:'     
           /       \             


 [+] scanning for wireless devices...
 [+] available wireless devices:
  1. phy3   wlan0       ath9k       Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
  2. phy2   wlan1       ath9k_htc   Atheros Communications, Inc. AR9271 802.11n
 [+] select number of device to put into monitor mode (1-2): 1
 [+] enabling monitor mode on phy3... done
 [+] available wireless devices:
  1. phy3   wlan0       ath9k       Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
  2. phy2   wlan1       ath9k_htc   Atheros Communications, Inc. AR9271 802.11n
 [+] select number of device to put into monitor mode (1-2): 2
 [+] enabling monitor mode on phy2... done
 [+] available wireless devices:
  1. phy3   wlan0       ath9k       Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
  2. phy2   wlan1       ath9k_htc   Atheros Communications, Inc. AR9271 802.11n
 [+] select number of device to put into monitor mode (1-2):
  • 1
    You don't need to use the TL-WN772N wifi adapter , the AR9485 support the monitir mode – GAD3R Sep 14 '16 at 21:17
  • I know, I used it previously but I'm using this adapter now. – qoph Sep 14 '16 at 22:48
0

To disable wlan0 , unload the ath9k driver:

 rmmod ath9k 

To disable it at boot add the following line to your /etc/modprobe.d/blacklist.conf:

blacklist ath9k

To enable it again , remove blacklist ath9k from blacklist.conf and run:

modprobe ath9k
| improve this answer | |
  • Ok thanks, I'll try it out. rmmod ath9k worked for me right away, added blacklist ath9k to /etc/modprobe.d/blacklist-libnfc.conf so I'll restart and test it. – qoph Sep 14 '16 at 23:24
1

If you have already tried the ifconfig wlan0 down / up routine, try to run also: airmon-ng check kill

It will kill some of the conflicting processes (like Network Manager). Probably this will be enough. Also it's worth noticing that the TL-WN772N has two versions with different chipsets. If you have v2, I think you're out of luck.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.