3

My mousepad is not working after suspend on a Lenovo E460. It used to work perfectly but after this it no longer even appears in xinput. I have tried to plug in a mouse and that works fine.

Edit: Restarting etc. does not make it work again, it is completely gone as of after the suspend.

  • Known bug with intel video driver: bugs.launchpad.net/ubuntu/+bug/1573454 – Ipor Sircer Sep 14 '16 at 16:51
  • 1
    This is not the same bug as I stated, Their issue is with the pointer not being visible while mine is the entire touchpad is not being recognized. The workarounds for that bug does not work for me. – ADan Sep 14 '16 at 18:52
  • Did you suspend to RAM or suspend to disk (= hibernate)? – imz -- Ivan Zakharyaschev Feb 5 '17 at 23:41
5

Editing the grub file from,

GRUB_CMDLINE_LINUX=""

to,

GRUB_CMDLINE_LINUX="i8042.reset i8042.nomux i8042.nopnp i8042.noloop"

then updating grub solved the problem.

  • What does this fix do? I put it in /etc/default/grub and it fixed it for Fujitsu Lifebook T725, but I don't understand why it works now. Will it have any side effects? – Joshua Detwiler Jul 20 at 23:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.