2
root@kali:~# apt-get install shutter
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 shutter : Depends: libgnome2-perl but it is not going to be installed
           Depends: libgnome2-vfs-perl but it is not going to be installed
           Depends: libgnome2-wnck-perl but it is not going to be installed
           Depends: libgnome2-gconf-perl but it is not going to be installed
           Depends: perlmagick
           Depends: libproc-simple-perl but it is not going to be installed
           Depends: libfile-which-perl but it is not going to be installed
           Depends: libsort-naturally-perl but it is not going to be installed
           Depends: libgtk2-imageview-perl but it is not going to be installed
           Depends: libgnome2-canvas-perl but it is not going to be installed
           Depends: libgtk2-unique-perl but it is not going to be installed
           Depends: libproc-processtable-perl but it is not going to be installed
           Depends: libpath-class-perl but it is not going to be installed
           Depends: libjson-perl but it is not going to be installed
           Depends: libjson-xs-perl but it is not going to be installed
           Depends: libnet-dropbox-api-perl but it is not going to be installed
           Recommends: libgoo-canvas-perl but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@kali:~# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  ax25-node caribou-antler castxml creepy dff gccxml gir1.2-clutter-gst-2.0
  gir1.2-gkbd-3.0 gir1.2-xkl-1.0 gnome-icon-theme-symbolic gtk2-engines
  gucharmap inguma libasn1-8-heimdal libavcodec-ffmpeg56 libavdevice-ffmpeg56
  libavfilter-ffmpeg5 libavformat-ffmpeg56 libavresample-ffmpeg2
  libavutil-ffmpeg54 libax25 libbasicusageenvironment0 libbind9-90
  libboost-atomic1.58.0 libboost-chrono1.58.0 libboost-date-time1.58.0
  libboost-filesystem1.58.0 libboost-python1.58.0 libboost-python1.61.0
  libboost-system1.58.0 libboost-thread1.58.0 libcamel-1.2-54
  libclutter-gst-2.0-0 libcrypto++9v5 libdbus-1-dev libdns100
  libexporter-tiny-perl libgconf2-4 libgdict-1.0-9 libgif4 libgnome2-0
  libgnome2-bin libgrilo-0.2-1 libgroupsock1 libgssapi3-heimdal libgtkglext1
  libgucharmap-2-90-7 libhcrypto4-heimdal libhdb9-heimdal libheimbase1-heimdal
  libheimntlm0-heimdal libhunspell-1.3-0 libhx509-5-heimdal libical1a
  libilmbase6v5 libisc95 libisccc90 libisccfg90 libjansson4 libjasper1
  libkdc2-heimdal libkrb5-26-heimdal liblist-moreutils-perl liblivemedia23
  libllvm3.7 liblouis9 liblwres90 libntdb1 libopenexr6v5 libopenjpeg5 libpff1
  libpgm-5.1-0 libpoppler57 libpostproc-ffmpeg53 libprotobuf-lite9v5 libpth20
  libpython3.4-minimal libpython3.4-stdlib libqmi-glib1 libquvi-scripts
  libquvi7 libregfi0 libroken18-heimdal libsodium13 libstreamanalyzer0v5
  libstreams0v5 libswresample-ffmpeg1 libswscale-ffmpeg3 libtask-weaken-perl
  libtre5 libtrio2 libusageenvironment1 libusbmuxd2 libuv1 libwebp5
  libwebpdemux1 libwebpmux1 libwebrtc-audio-processing-0 libwind0-heimdal
  libwireshark6 libwiretap5 libwsutil6 libx265-68 libyara3 libzip2 libzmq3
  multiforcer oxygen5-icon-theme python-apsw python-bluez
  python-characteristic python-ctypeslib python-dbus-dev python-distlib
  python-dominate python-ecdsa python-flickrapi python-googleapi
  python-instagram python-jwt python-lzma python-lzo python-magic python-ntdb
  python-oauth2client python-oauthlib python-opengl python-pyatspi
  python-pyexiv2 python-pyexiv2-doc python-pyqtgraph python-qt4-gl
  python-qt4-phonon python-requests-oauthlib python-requests-toolbelt
  python-rsa python-tidylib python-tweepy python-uritemplate python-yapsy
  python3.4 python3.4-minimal ratproxy ruby-rainbow ruby-rexec ruby2.2-dev
  system-config-printer
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  libart-2.0-2 libbonoboui2-0 libbonoboui2-common libclass-accessor-perl
  libclass-data-inheritable-perl libclass-method-modifiers-perl
  libcommon-sense-perl libcrypt-openssl-bignum-perl libcrypt-openssl-rsa-perl
  libdata-random-perl libfile-which-perl libgd-perl libgnome2-canvas-perl
  libgnome2-gconf-perl libgnome2-perl libgnome2-vfs-perl libgnome2-wnck-perl
  libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-0 libgnomeui-common
  libgtk2-imageview-perl libgtk2-unique-perl libgtkimageview0
  libimage-magick-perl libimage-magick-q16-perl libjson-perl libjson-xs-perl
  libmouse-perl libnet-dropbox-api-perl libnet-oauth-perl libpath-class-perl
  libproc-processtable-perl libproc-simple-perl libsort-naturally-perl
  libtypes-serialiser-perl libunique-1.0-0 libwnck-common libwnck22 perlmagick
Suggested packages:
  imagemagick-doc libmojolicious-perl
The following NEW packages will be installed:
  libart-2.0-2 libbonoboui2-0 libbonoboui2-common libclass-accessor-perl
  libclass-data-inheritable-perl libclass-method-modifiers-perl
  libcommon-sense-perl libcrypt-openssl-bignum-perl libcrypt-openssl-rsa-perl
  libdata-random-perl libfile-which-perl libgd-perl libgnome2-canvas-perl
  libgnome2-gconf-perl libgnome2-perl libgnome2-vfs-perl libgnome2-wnck-perl
  libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-0 libgnomeui-common
  libgtk2-imageview-perl libgtk2-unique-perl libgtkimageview0
  libimage-magick-perl libimage-magick-q16-perl libjson-perl libjson-xs-perl
  libmouse-perl libnet-dropbox-api-perl libnet-oauth-perl libpath-class-perl
  libproc-processtable-perl libproc-simple-perl libsort-naturally-perl
  libtypes-serialiser-perl libunique-1.0-0 libwnck-common libwnck22 perlmagick
0 upgraded, 40 newly installed, 0 to remove and 391 not upgraded.
1 not fully installed or removed.
Need to get 0 B/4,190 kB of archives.
After this operation, 16.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
apt-listchanges: APT_HOOK_INFO_FD environment variable is incorrectly defined
(Dpkg::Tools::Options::/usr/bin/apt-listchanges::InfoFD should be greater than 2).
E: Sub-process /usr/bin/apt-listchanges --apt || test $? -ne 10 returned an error code (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -ne 10
root@kali:~# /usr/bin/apt-listchanges --apt || test $? -ne 10
apt-listchanges: APT_HOOK_INFO_FD environment variable is not defined
(is Dpkg::Tools::Options::/usr/bin/apt-listchanges::InfoFD set to 20?)
root@kali:~# 

How can I solve the dependency problem and get shutter installed?

  • Please add the output of apt-cache policy apt-listchanges – GAD3R Sep 14 '16 at 13:41
  • root@kali:~# apt-cache policy apt-listchanges apt-listchanges: Installed: 3.3 Candidate: 3.3 Version table: *** 3.3 500 500 http.kali.org/kali kali-rolling/main amd64 Packages 100 /var/lib/dpkg/status root@kali:~# – sukihinata Sep 14 '16 at 13:48
2

Perhaps this could help you out:

mv /etc/apt/apt.conf.d/20listchanges.dpkg-new /etc/apt/apt.conf.d/20listchanges
apt-get -f install

If that doesn't help try rebooting or add this line to /etc/apt/apt.conf.d/20listchanges:

DPkg::Tools::Options::/usr/bin/apt-listchanges::InfoFD "20";
  • Glad to hear that. – Erik van de Ven Sep 14 '16 at 13:57
  • @sukihinata Great! please , do not forget to accept it . – GAD3R Sep 14 '16 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.