2

I've got Windows and Ubuntu installed. After turning off secure boot and selecting legacy boot mode, I proceeded with installation of Kali Linux from the flash drive.

During the installation I have been warned that the only other OS detected was Ubuntu and it asked whether it want to store it in MBR or hard for booting unfortunately I selected Yes.

Now I am unable open my windows 10. What shall I do now to show my Windows 10 in GRUB2 menu?

  • In what order did you install Ubuntu and Windows? How were you able to boot into these two OSes? – MatthewRock Sep 14 '16 at 9:28
  • please add the output of fdisk -l – GAD3R Sep 14 '16 at 9:46
  • /dev/sda1 -windows recovery environment – naveen8577 Sep 14 '16 at 10:57
  • @MatthewRock /dev/sda1 windows recovery environment – naveen8577 Sep 14 '16 at 10:59
  • 1
    @GAD3R /dev/sda2 EFI system dev/sda3 Microsoft reserved. /dev/sda4,5 Microsoft basic data /dev/sd6 -windows recovery environment /dev/sda 7 Linux swap /dev/sd8 Linux filesystem /dev/sda9 Linux filesystem – naveen8577 Sep 14 '16 at 11:08
1

The problem is that Kali's grub does not see Windows. Ubuntu did. I suggest that you follow this guide and "repair" grub. This should install grub once again, and Ubuntu should be able to detect all OSes correctly.

  • That would be the case, and a good suggestion, had they not mentioned the requirement to disable secure boot when installing Kali which suggests they have Windows installed with GPT and Kali on MBR so unfortunately no amount of repairing Kali's grub will solve this one. – I_GNU_it_all_along Sep 14 '16 at 11:45
0

If you switch your BIOS back to secure mode using UEFI, it should boot into Windows.

Unfortunately, GPT and MBR aren't compatible and, unless I've missed the release of a new tool that allows you to jump between them conveniently, this is unfortunately what you'll have to do to boot into the other OS.

0

First, you need to backup your data , to boot windows you can use Super Grub2 Disk, witch allow you to boot a different OS , legacy or UEFI .

Because GRUB does not understand GPT partition tables, you need to create a bios_grub partition then reinstalling Grub , also the os-prober need to be installed to get the others OS detected.

Note: For GRUB to boot from a GPT-partitioned disk on a BIOS-based system, a BIOS boot partition is required. Please note that this partition is unrelated to the /boot mountpoint, and will be used by GRUB directly. Do not create a filesystem on it, and do not mount it.

What is the bios_grub partition?

The BIOS boot partition is a partition on a data storage device that GNU GRUB uses on legacy BIOS-based personal computers in order to boot an operating system, when the actual boot device contains a GUID Partition Table (GPT). Such a layout is sometimes referred to as BIOS/GPT boot.

Why?

A BIOS boot partition is needed because GPT uses the disk sectors immediately following the Master Boot Record (MBR) to hold the actual partition table, whereas the traditional MBR-based partitioning scheme does not designate them for any special purpose. As a result, there is not enough unused space available for storing second stages of boot loaders on GPT disks; boot loaders are usually implemented so their code stored within the MBR, which cannot hold more than 512 bytes, operates as a first stage that serves primarily to load a more sophisticated second stage, which is, for example, capable of reading and loading an operating system kernel from a file system.

0

MBR-GPT incompatibility on UEFI system

This problem also occurs when Windows is installed on one drive in MBR mode and Linux/Grub2 is installed on a second drive in GPT mode. The MBR drive is recognized as a boot option by UEFI only under compatibility mode while the GPT drive is recognized only under EFI boot mode. If that's the case, this solution should work:

Reboot to Grub2, and there should now be an option for Windows.

0

I had this problem too but with ubuntu https://askubuntu.com/questions/879605/trouble-with-windows-10-ubuntu-16-10 . All I had to do was opening a terminal and issuing the comand sudo update-grub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.