0

I am new to puppet,Have tried to install puppet enterprise 2016.2 in my local machine(monolithic method)

  • downloaded tar file and extracted it
  • gave the option as Guided install option
  • It popped out with message as Please go to https:/hostname/:3000 in your browser to continue installation
  • Opened the page and followed the instructions given in puppet labs and in final verfication steps it popped with error message , instructed me to check logs

While going through logs unfortunately my machine got crashed and rebooted

And I tried to open the console but it wasn't so i ran the script .puppet-enterprise-uninstaller to unistall . Then tried to install again using the script /puppet-enterprise-installer but it was stopped with below lines and not proceeding further (also unable to access the https:/hostname/:3000)

# We're preparing the Web Installer...

./puppet-enterprise-installer: line 502: /opt/puppetlabs/puppet/bin/facter: No such file or directory
2016-09-14 10:58:50,887 Running command: mkdir -p /opt/puppetlabs/puppet/share/installer/installer
2016-09-14 10:58:50,890 Running command: cp -pR /tmp/puppet-enterprise-2016.2.1-el-6-x86_64/* /opt/puppetlabs/puppet/share/installer/installer/
Please go to https://:3000 in your browser to continue installation. Be sure to use 'https://' and that port 3000 is reachable through the firewall.
2016-09-14 10:58:51,101 Running command: RACK_ENV=production /opt/puppetlabs/puppet/bin/bundle exec thin start --debug -p 3000 -a 0.0.0.0 --ssl --ssl-disable-verify &> /dev/null

Please guide on this

  • You are trying to install puppet again after a crash, that's blatantly wrong. You did not investigate the crash, or looked at the logs of what puppet managed to do and what it didn't. The logs are much more useful to debug this than the installer. – grochmal Oct 11 '16 at 20:36
0

Make sure you're installing as root (also, make sure that root is allowed to SSH to itself on the machine. verify by typing "ssh root@localhost"). Make sure you have access to port 3000 on the system you're installing. So if you're installing on a local vm, ensure port 3000 is open, or ensure you're using SSH tunneling and tunnel port 3000 back to your local machine through port 22.

Ensure you follow all the directions here:

https://docs.puppet.com/puppet/3.8/reference/pre_install.html

  • OPs puppet caused a crash, and he is not providing the logs. He is not using a VM. And moreover, he is not providing enough info about the crash. The crash should be focus here. – grochmal Oct 11 '16 at 20:36
  • Ah, I see now. Not really sure why you'd install on a local machine anyway. Good point. – clattems Oct 11 '16 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.