1

I just installed ibus. However, it appears to be overriding some of my xorg.conf rules. I have a file at /etc/X11/xorg.conf.d/10-general-xkb.conf, which includes the following line.

Option "XKbOptions" "lv3:ralt_switch_multikey,numpad:pc,ctrl:swapcaps"

This swaps Ctrl and Caps Lock. However, my primary ergonomic keyboard already has these keys in the correct place. Hence, I have another file at /etc/X11/xorg.conf.d/11-TECK-keymap.conf that matches this keyboard (with MatchProduct), then applies the following line.

Option "XKbOptions" "lv3:ralt_switch_multikey,numpad:pc"

This overrides the previous options, leaving Ctrl and Caps Lock as default.

However, after installing ibus, I'm finding that the second xorg.conf file is not firing correctly. After restarting my computer, or switching ibus layouts, I have the first, incorrect xorg layout, i.e. the ctrl:swapcaps option is incorrectly applied to my ergonomic keyboard. If I manually remove and plug back in the USB cable, then the layout is correct again. Is there a way to use ibus with xorg.conf rules?

FWIW the following is in ~/.xprofile.

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
ibus-daemon -drx

I'm using KDE Plasma 5 and an up-to-date Arch Linux system.

EDIT

If this is not possible, an ugly hack might be to rebind the "switch ibus layout" key to reload the xorg.conf rules after switching. I can't find a way to reload these rules though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.