4

Situation: to have Advanced search (like Adobe Acrobat's one) in any pdf reader; search many documents and have integrated view for their review

I know the thread about installing Adobe reader by in the thread How to install Adobe Acrobat Reader in Debian? where I tried

  • its current accepted answer is about the installation of the old version (9.0) of Adobe reader here
  • terdon's answer about adding Linux Mint's reporisitory of acroread in Debian but the source does not work

I know the answer in the thread How to Install Adobe Acrobat in Ubuntu 16.04? about adding a repository, but there is no command add-apt-repository "deb http://archive.canonical.com/ precise partner" in Debian. I can recall that you can get Adobe Reader 10 and/or newer by this method. I would like to get at least the same in Debian.

OS: Debian 8.5 64 bit
Linux kernel: 4.6
Hardware: Asus Zenbook UX303UA
Architecture: amd64

3

Adobe Reader is no longer supported by Adobe on Linux since 2014. Adobe no longer provides security updates for Adobe Reader under Linux.

How to Install adobe reader-enu in 64-bit Debian 8.5?

wget ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
sudo apt-get install gdebi
sudo gdebi AdbeRdr9.5.5-1_i386linux_enu.deb
sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386
sudo apt-get -f install
  • 2
  • 1
    @MatteoItalia It would be nice if such VBs could be done with minimal memory and minimal interface. - - Current environment is just not sufficient for my tasks in isolated environment. - - It would be nice to understand why Advanced search cannot be implemented for any pdf reader in Linux. – Léo Léopold Hertz 준영 Sep 12 '16 at 16:35
  • You're not actually installing the 64-bit version using this approach It's so clear that the package is 32-bit and installing the extra packages won't actually make any change to that – Mehdi Mar 25 '18 at 2:29
5

The last version of Adobe Reader available on Linux is 9.5.5, even in Canonical's partner repository. Adobe Reader has been unsupported on Linux for quite a while, I dare say there are probably a few security vulnerabilities lurking...

You should use Okular or Evince.

If you need features which are only available in Adobe Reader, you should run it in a virtual machine to reduce the level of risk; either version 9.5.5 in a Linux VM, or the current release in a Windows VM (assuming you have the appropriate license). If you take the Linux VM route, you might as well make it a 32-bit VM since that will simplify the installation of Adobe Reader (gdebi will do the right thing on its own, see GAD3R's answer).

  • 3
    You should mention that in your question... If you need features which are unique to Adobe Reader (and I think multi-document search is indeed not available anywhere else, even Foxit Reader) then you need to run Adobe Reader. To reduce the risk, you should run it in a VM — either the old 9.5.5 release in a Linux VM, or (if you have a Windows license) the current release in a Windows VM. – Stephen Kitt Sep 12 '16 at 9:12
1

I'm not sure about Debian, but I'm guessing this would work ... I got it to install in Ubuntu 16.04 LTS / Mint 18 by doing the following with elevated permissions (e.g. sudo, su root, etc.):

# add-apt-repository "deb http://archive.canonical.com/ precise partner"   
# apt update

Search for the acroreader package using apt after adding the archive repository (where it is located):

# apt search adobereader

There are a few different language versions, such as -enu (English), -deu (German), -fra (French) and -jp (Japanese). I chose English, so I'll use that in my example.

But first, you have to install a couple required libraries:

# apt install libatk-adaptor:i386 libgail-common:i386

Then install the package itself:

# apt install adobereader-enu

Without being root (e.g. don't type sudo), invoke the following at prompt to load the program:

$ acroread

Takes a while to run for the first time because it loads a license / TOS it wants you to agree to. You only have to do this once.

Seems to work pretty good despite the dodgy 32-bit libraries. Works better than the version available in the Arch Linux AUR (which takes a fair bit of hacking) which I used for work for nearly a year without problem.

Hope that helps...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.