5

Today I finally decided to switch from Windows to Ubuntu. I fully install Ubuntu, but everytime my notebook goes in sleepmode and wakes up my mouse will not work anymore. When I do a reboot it works fine until I let it sleep (even if it's for 10sec).

So I tried switching to Mint, however even with Mint I had the same problem. I have been trying to fix it all day without success.

Notebook: Asus laptop

On a similar forum post this was the fix:

sudo apt-get install --reinstall xserver-xorg-input-all

However this did not work for me.

4

This issue goes back at least a couple of years. It's a problem for a lot of Asus owners, but it's not entirely specific to Asus devices. Also, it's not Debian-specific — though in your case both Ubuntu and Mint have Debian roots.

It's a tricky one because it seems everyone's mileage varies with each proposed solution (and they all have slight hardware variances). There are countless threads trying to solve it.

Notable bug threads on Launchpad (depending on your Asus model):

Applicable bug thread on Kernel.org:

Assuming you don't want to patch your kernel, there are a couple potential runtime solutions you can try.

(Note: You can open a terminal with Ctrl+Alt+T)

Disable/Enable the Mouse Driver:

You can remove and then re-insert your mouse driver module with the following commands:

sudo modprobe -r psmouse
sudo modprobe psmouse

Disable/Enable via Xinput:

Find your trackpad ID with the following command:

xinput --list

Once you have your device ID—I'll call it 12 for this example—try disabling and enabling the device with:

xinput --disable 12
xinput --enable 12

(Replace 12 with your trackpad's device ID)

Alternative:

As an aside, you may want to try hibernating instead of suspending. Supposedly the problems aren't as prevalent with hibernation.

  • Disable/Enable the Mouse Driver worked for me (sudo modprobe -r psmouse / sudo modprobe psmouse). Hint: I added this to my ~/.gnomerc so it is called every time I log in. – cheneym Apr 23 '18 at 11:41
4

I can confirm a similar issue with my touchpad on HP ProBook 450 G6 with Ubuntu 18.04, it was very laggy after suspend.

What worked for me: create /lib/systemd/system-sleep/touchpad:

#!/bin/sh

case $1 in
  post)
    /sbin/rmmod i2c_hid && /sbin/modprobe i2c_hid 
  ;;
esac

make file executable chmod +x /lib/systemd/system-sleep/touchpad and test (suspend computer and wake-up again)

  • Just got an HP Probook 440 G6 and installed Xubuntu 18.04, and had the same issue. Blindly followed these instructions with zero attempt at understanding why :) Works great now! +1 – LedHead Sep 14 at 23:23
1

What I do to restart the touchpad driver is similar to what Tom Hale suggested. I created a script called touch_restart.sh:

#!/bin/bash
$sudo rmmod i2c_hid && $sudo modprobe i2c_hid

and then you can always execute it quickly with: echo "su_pass"|sudo -S sh touch_restart.sh

Also, it seems that disabling "Disable touchpad when typing" increases the periods between each touchpad freeze (it freezes very often on my Asus laptop).

0

I call this script mouse-reset. It removes and then modprobes a list of mouse-related modules:

#!/bin/bash

modules=(psmouse hid_multitouch elan_i2c)

for mod in "${modules[@]}"; do
    sudo rmmod "$mod" 2> /dev/null
    sudo modprobe -v "$mod" 2> /dev/null
done
0

Ubuntu gnome tweaks has a feature called disable touchpad while typing. Some times disabling that feature worked for me. I currently use ubuntu 18.04

Tweaks -> keyboard & Mouse -> touchpad -> disable while typing

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.