13

Linux Mint 12 (64bit), on an Acer Aspire 7730g. Upon every boot, the screen brightness is set very very low. Easily fixed via the function keys, but still a very annoying thing to do after every boot. Is there a way to set the brightness permanently?

NB: Interestingly, I had the same problem when Ubuntu was installed on the same laptop, so I'm a bit perplexed about how did this setting survive a complete OS reinstall?

dmesg output available here.

Another update: I don't know if this is related, but every time I reboot, my wireless is off, bluetooth is on, and Num Lock is off; all three the exact opposite of what I want them to be. If this is not related, it may become another question.

8
  • Does this help? blog.ishans.info/2011/09/25/…
    – user14517
    Commented Feb 5, 2012 at 15:23
  • Could you please post your dmesg on pastebin?
    – bsd
    Commented Feb 5, 2012 at 15:43
  • @bdowning: Updated the question! Commented Feb 5, 2012 at 16:49
  • @Nunoxic: Wouldn't this require me to add it for every user? The "blackout" occurs on login screen, so I'm not sure if this would be as practical. (Unless I misunderstood and this works even before login?) Also, unlike that guy's problem, there is no change of brightness on login/logout, is that a significant difference? Commented Feb 5, 2012 at 16:52
  • I'm not so sure. You could give it a try if you are not averse to the idea of experimenting a little. It could, of course, be risky.
    – user14517
    Commented Feb 5, 2012 at 17:39

2 Answers 2

11

Your laptop should have /sys/class/backlight. For example, /sys/class/backlight/acpi_video0/brightness. You can write (echo) values to this file to adjust brightness.

cat /sys/class/backlight/acpi_video0/max_brightness > /sys/class/backlight/acpi_video0/brightness

This will set the brightness to max. Just put it in an init script on boot.

2
  • 3
    Many distros use the /etc/rc.local init script for running programs after boot.
    – user13742
    Commented Feb 5, 2012 at 18:02
  • Success! I added that to /etc/rc.local as @hesse said and it works, half a second after the login screen shows up it toggles the brigthness. Thanks! Commented Feb 5, 2012 at 19:54
3

my x120e's brightness constantly changing bothers me as well. surprisingly (but not), when i ran

gksudo dmesg > boot.messages

and opened boot.messages in a text editor, i noticed this message:

[Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness

multiple times, as well as some interesting others. paste that into Google and you'll find Cannibal's Candy [wordpress] - who provides an in-depth look at ACPI and a method for universally setting the screen brightness (+ so much more):

DSDT editing: Put an end to your ACPI woes

yep, prepare your mind to be blown. i'm working through CC's post right now, but thought i would share. best of luck!


running Linux Mint Debian (amd64) on a Thinkpad x120e

1
  • My goodness. This is hardcore. The link talks about learning a whole new language. I think I'll stick to changing the brightness manually for now!
    – LondonRob
    Commented Jul 26, 2014 at 23:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .