0

I'm on Fedora 24 and am trying to print.

My printer is a Brother MFC-J6520DW which worked well on Debian. I installed the driver from Brother's webpage.

Whenever I try to print a test page, the printer status never gets beyond "Processing - Waiting for job to complete". On the screen of the printer itself it says "Retrieving Data". After a very long time (some minutes) the printer releases an empty page.

The printer sits on a network and works fine from other non-Fedora devices.

I have tried the following:

  • explicitly allow MyUser in the CUPS webinterface (locahost:631)
  • ensured that the ipp and ipp-client services are trusted by the firewall (I understand that these are needed for printing).

Not really sure what to do next to try to fix this....

closed as off-topic by Jeff Schaller, countermode, thrig, Satō Katsura, mdpc Mar 1 '17 at 22:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, countermode, thrig, Satō Katsura, mdpc
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Look at /var/log/cups/* – waltinator Sep 11 '16 at 16:34
  • @waltinator, there is access_log in there as well as page_log, however both files seem to be empty – pandita Sep 11 '16 at 21:02
1

I've just had the same problem, albeit with a Canon MF229dw on Linux Mint, butg the solution was simply to change the connection type to "AppSocket/HP JetDirect".

  • Thanks Colin. I upgraded to Fedora 25 and the problem disappeared.... I'll check what connection type F25 offers and if this is the same – pandita Dec 18 '16 at 3:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.