1

I removed previous version of firefox and I downloaded the 45.3.0esr. I moved it to /home/user/firefox. Obviusly, if I type:

firefox

It raises:

bash: /usr/bin/firefox: No such file or directory

So I changed .bashrc and .bash_profile adding this line:

export PATH="$PATH:/home/user/firefox/"

But the problem persist.. in fact:

firerox

Raises always the same error:

bash: /usr/bin/firefox: No such file or directory

What can I do? I know I can just open it typing ./home/user/firefox/firefox-bin but I need to open with firefox command cause another program requires that (selenium).

I'm running ArchLinux.

  • What happens if you type hash -r, or logout and login again? Do you have any aliases? – Stephen Harris Sep 10 '16 at 14:00
  • export PATH="/home/user/bin/override/:$PATH:/home/user/bin", then put most of your own bins in /home/user/bin and ones to override system, in /home/user/bin/override. – ctrl-alt-delor Sep 10 '16 at 15:49
2

Modifying PATH will not solve the problem. The error message says it is looking for a specific pathname. You could appease it by doing

sudo ln -s /home/user/firefox /usr/bin/firefox

assuming that "firefox" in your home-directory is

  1. a filename, and
  2. there is no dangling symbolic link /usr/bin/firefox
  3. has no other dependencies...

The comment about /home/user/firefox/firefox-bin indicates that "firefox" is a directory, so...

sudo ln -s /home/user/firefox/firefox-bin /usr/bin/firefox

seems to be what you might want to do.

0

I had a similar problem, but in my case I just used firefox package different architecture. My system is x64, I tried used 386 firefox package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.