In order to mount my /dev/sda4 under /mnt/ufs_mount on Debian Testing , i have tried the following commands (it works fine under Debian Jessie):

modprobe ufs
mount -r -t ufs -o ufstype=ufs2 /dev/sda4 /mnt/ufs_mount


mount -t ufs -o ufstype=ufs2 /dev/sda4 /mnt/ufs_mount

But i get this error:

mount: /dev/sda4 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sda4,
   missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.

The output of: dmesg | tail :

[ 1136.965142] ufs: ufs_fill_super(): bad magic number
[ 1255.758946] ufs: ufs_fill_super(): bad magic number
[ 2098.945757] ufs: ufs was compiled with read-only support, can't be mounted as read-write
[ 2098.946045] ufs: You didn't specify the type of your ufs filesystem

      mount -t ufs -o ufstype=sun|sunx86|44bsd|ufs2|5xbsd|old|hp|nextstep|nextstep-cd|openstep ...

      >>>WARNING<<< Wrong ufstype may corrupt your filesystem, default is ufstype=old
[ 2098.967212] ufs: ufs_fill_super(): bad magic number
[ 2927.982112] perf: interrupt took too long (2504 > 2500), lowering kernel.perf_event_max_sample_rate to 79750

Edit My sources.list:

deb http://httpredir.debian.org/debian/ stretch main
deb-src http://httpredir.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

And uname -a:

Linux debian 4.6.0-1-amd64 #1 SMP Debian 4.6.4-1 (2016-07-18) x86_64 GNU/Linux

How to mount ufs file system under Debian testing?

  • 1
    Were you able to mount the filesystem in the past? Sep 9 '16 at 18:54
  • @StephenKitt , On debian jessie , i am able to mount the /dev/sda4 without any problem.
    – GAD3R
    Sep 9 '16 at 19:02
  • The message about FS subtype seems indicative. Have you tried using that line for a manual mount attempt?
    – Shadur
    Sep 10 '16 at 16:00

According to mount freebsd slice partition under linux, you may need to specify an offset into the partition.

partx -l should be able to identify the sector offset of the filesystem, which you'd need to multiply by 512. You can pass that as a mount option using -o offset=$((512*sector_offset)) - assuming you're using bash or a similar shell.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.