-1

Why can't I run this .sh file? I'm root, the file has execute permissions. What else?

enter image description here

closed as off-topic by Stephen Harris, GAD3R, Archemar, dr01, Anthony Geoghegan Sep 9 '16 at 13:30

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Stephen Harris, GAD3R, Archemar, dr01, Anthony Geoghegan
If this question can be reworded to fit the rules in the help center, please edit the question.

3

The problem is that this is a bash script, but you are running it with sh. If you run sudo bash ./run.sh it should work.

  • That returns the same error – Richard Sep 9 '16 at 8:37
  • The error you are getting is coming from line 42 of the script. Is it possible, that there is a error? – lw1.at Sep 9 '16 at 8:39
  • 1
    Ohhh. I see the script is running, but it is broken. Thanks! – Richard Sep 9 '16 at 8:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.