1

I am using a ThinkPad P50s, CentOS7 with the most up to date kernel, and I have already tried Ctrl+Alt+F1 and then Ctrl+Alt+F2 in an attempt to switch the monitor on.

On wake-up, I know that the system is running because music will play whilst my screen remains completely black.

Information that might be useful is that 'systemctl hibernate' will fail to work as 'a dependency job for hibernate.target failed'.

This was a minimal install with GNOME loaded on top afterwards, so I am unsure if I am missing important dependencies, but even then I would not know how to remedy that.

  • Same issue - Only on a dell something or another. – rm-vanda Mar 15 '17 at 21:28
  • @rm-vanda this problem was "solved" by the latest centos update, but the problem with my graphics card not registering still isn't fixed – spoon_seth Mar 16 '17 at 0:11
  • see if that works for you - if not, then you could always try installing the proprietary drivers, albeit I'm sure you've tried that, already.. – rm-vanda Mar 17 '17 at 18:49
1

sleep & wake was working great on RHEL v7.5 with Thinkpads T450/460/470 but after Sep 2018 kernel updates it was ruined.

https://bugzilla.redhat.com/show_bug.cgi?id=1628958

Screen now stays blank after wake up. Only Keyboard leds wakeup. only solution in RHEL 7.5 now is to force full shutdown.

Red hat is somewhat aware of the situation but none of their solution works. not even https://access.redhat.com/discussions/3523071#comments I believe the same problem exists in CentOS 7.5

As opposed to what was written here Kernel 3.0 was working great till a month ago.

uname -a Linux my-thinkpad 3.10.0-862.11.6.el7.x86_64 #1 SMP Fri Aug 10 16:55:11 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

the problem was solved by removing the bad update. Did a yum downgrade microcode_ctl and added microcode_ctl to the exclude list in /etc/yum.conf. After a reboot, sleep&esume working again like before.

problem with RHEL update:

RHEA-2018:2397 - Product Enhancement Advisory: microcode_ctl bug fix and enhancement update

microcode_ctl-2.1-29.16.el7_5.x86_64.rpm

now fixed

``` Removed: microcode_ctl.x86_64 2:2.1-29.16.el7_5

Installed: microcode_ctl.x86_64 2:2.1-29.10.el7_5

```

do not install https://access.redhat.com/errata/RHEA-2018:2397

  • For the record, this doesn't address the original question, which was posted a long time before the bad microcode_ctl update. Also, instead of setting exclude=microcode_ctl in yum.conf, if we are optimistic that the next version will have this issue fixed we can exclude just the bad version: exclude=microcode_ctl-2.1-29.16.el7_5. – doshea Oct 2 '18 at 1:28
0

The reason for this, as we've encountered, is that since the CentOS/RHEL kernels are made for server and not for desktop, and thus new hardware doesn't run very well on those kernels.

Therefore, the solution is simply to install a newer, >4.0 kernel that supports the newer hardwares. The latest stable right now is 4.10.3 which is in the kernel-ml package in the elrepo. kernel-lt is an alternative solution, but in this case, I would recommend kernel-ml

Since this package always contains the latest stable kernel, these instructions will likely not change for the foreseeable future.

To upgrade your kernel to the latest stable, simply follow these instructions taken from this site

To install the latest kernel, add ELRepo repository.

Add ELRepo GPG key:

# rpm --import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org

Then, add ELRepo in CentOS 7 / RHEL 7 / Scientific Linux 7 using command:

# rpm -Uvh http://www.elrepo.org/elrepo-release-7.0-2.el7.elrepo.noarch.rpm

Enable ELRepo fastest mirror using by installing the following package:

# yum install yum-plugin-fastestmirror

Next, enable ELRepo and install Linux Kernel 4.10 version using command:

yum --enablerepo=elrepo-kernel install kernel-ml

Finally, reboot, and uname -r should show 4.10 among some other numbers, but you will also see it on your grub menu when you boot.

NOW the solution we are actually going with, is to reinstall the computer with Ubuntu and run CentOS in a virtual machine. To each their own - whatever solution works best for you.

  • its not the reason , server kernel worked great for me on my thinkpads with wake&sleep – taitelman Sep 27 '18 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.