0

I am trying to run yum upgrade on a server, it does virtually nothing...

[myusername@server-1 ~]$ sudo yum upgrade
Loaded plugins: fastestmirror
Setting up Upgrade Process
Determining fastest mirrors
[myusername@server-1 ~]$ █

I tried turning off the fastestmirror plugin and get this...

[myusername@server-1 ~]$ sudo yum upgrade
Freeing read locks for locker 0xXXXX: XXXXX/XXXXXXXXXXXXXXX
Freeing read locks for locker 0xXXXX: XXXXX/XXXXXXXXXXXXXXX
Setting up Upgrade Process
base                                                                 | 3.7 kB     00:00

(replaced actual numbers with X just in case here)

I tried rebooting. Same problem after reboot.

The server has plenty of spare ram and free disk space.

It is a rackspace server.

Edit: Output when using the verbose flag...

[myusername@server-1 yum.repos.d]$ sudo yum upgrade -v
Freeing read locks for locker 0xXXXX: XXXXX/XXXXXXXXXXXXXXX
Freeing read locks for locker 0xXXXX: XXXXX/XXXXXXXXXXXXXXX
Loading "fastestmirror" plugin
Config time: 0.010
Yum Version: 3.2.29
rpmdb time: 0.000
Setting up Upgrade Process
Updating Everything
Building updates object
Setting up Package Sacks
Determining fastest mirrors
[myusername@server-1 yum.repos.d]$
  • Do you have outgoing network from that machine? Notably to the URLs inside /etc/yum.repos.d/ – grochmal Sep 8 '16 at 0:05
  • Can you show us the output when you add the verbose flag? – sysadmiral Sep 8 '16 at 10:41
  • @grochmal I can ping them (or the ones I tried) and other sites from the server. – MrVimes Sep 8 '16 at 19:53
  • By any chance, do you have enabled=0 in all repos in /etc/yum.repos.d/*.repo ? You can set that to enabled=1. Also, you can comment out mirrorlist= and uncomment baseurl=; that would pass through a firewall that drops URL queries. – grochmal Sep 8 '16 at 20:17
  • Some of them had enabled=0 but not all (and presumably not the ones that matter) Anyway today I reset my root password, then tried after 'su', then got an extra error - 'illegal instruction' I've posted an answer to my question with more info. – MrVimes Sep 8 '16 at 23:05
0

I ran 'su' then got slightly more info -

Illegal instruction

I then googled this. Found this page - https://www.centos.org/forums/viewtopic.php?t=58002

Ran this command -

NSS_DISABLE_HW_GCM=1 yum upgrade

And the update process worked.

From that link...

I think the actual problem is that the cpuinfo says it has AES but when the system tries to use it, it discovers the support is not there - hence the illegal instruction crash. Have you for example booted this guest on a host machine that has aes-ni and then migrated to one that hasn't? Or overridden the processor type reported to the guest in some way?

You could use temporary fix of this problem, by setting the environment variable: "NSS_DISABLE_HW_GCM=1"

So for example if you run: NSS_DISABLE_HW_GCM=1 yum search some_package ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.