0

I cannot get xbacklight to work at all due to Centos 7 not supporting it.

I am using a thinkpad p50s. I would like to be able to then bind the command to the buttons meant for brightness but I am unable to do so.

This is the output from 'dmesg | grep thinkpad_acpi'

[ 3.579866] thinkpad_acpi: ThinkPad ACPI Extras v0.25

[ 3.579869] thinkpad_acpi: http://ibm-acpi.sf.net/

[ 3.579870] thinkpad_acpi: ThinkPad BIOS N1KET21W (1.08 ), EC unknown

[ 3.579871] thinkpad_acpi: Lenovo ThinkPad P50s, model 20FLCTO1WW

[ 3.587378] thinkpad_acpi: detected a 8-level brightness capable ThinkPad

[ 3.587409] thinkpad_acpi: radio switch found; radios are enabled

[ 3.587559] thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness control, supported by the ACPI video driver

[ 3.587560] thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...

[ 3.591080] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked

[ 3.591620] thinkpad_acpi: Standard ACPI backlight interface available, not loading native one

[ 3.591784] thinkpad_acpi: Console audio control enabled, mode: monitor (read only)

[ 3.593760] input: ThinkPad Extra Buttons as /devices/platform/thinkpad_acpi/input/input6

[ 10.154636] thinkpad_acpi: EC reports that Thermal Table has changed

  • p50s is equipped with Nvidia Maxwell M500M. Is this correct? What ls /sys/class/backlight/* shows? – Serge Sep 7 '16 at 3:16
  • @Serge 'no such file or directory' – spoon_seth Sep 7 '16 at 3:21
  • there is a backlight directory though I believe – spoon_seth Sep 7 '16 at 3:22
  • CentOS 7 must be running quite recent kernel. Strange... BTW, take a look: wiki.archlinux.org/index.php/Backlight May be one of recipes applies to your situation – Serge Sep 7 '16 at 3:37
1

Centos 7 has a kernel module to support acpi on thinkpad laptops. It sounds like you are either missing some boot parameters related to this or the thinkpad kernel module is not being loaded for some reason.

I just checked on my CentOS 7.2 server (which is not a thinkpad) and thinkpad_acpi was available (but not in use, obviously). I did a full install on that system; not a bare bones server config, so it should be similar to yours. Check to see if it's available and if it's currently on your machine with the following:

 lsmod | grep thinkpad_acpi
 modinfo thinkpad_acpi

lsmod lists the currently loaded kernel modules - thinkpad_acpi should be loaded. If it isn't, modinfo will inform us if the kernel module is available on your system. If it isn't, I believe you would have to recompile the kernel (at a minimum the modules after adding thinkpad_acpi using make menuconfig or equiv.).

Assuming that at least modinfo reported thinkpad_acpi was available, the next thing to check are your boot paramaters in grub. There are two non-standard boot parameters required for the thinkpad_acpi driver to take over backlight control, as follows:

thinkpad-acpi.brightness_enable=1 acpi_backlight=vendor 

To add these entries as kernel boot parameters:

1. Edit your grub configuration:

 sudo vi /etc/grub/menu

Check the line starting with GRUB_CMDLINE_LINUX= and make sure these settings, or conflicting settings, aren't already present. If they are not, append the new values to this line. It's fine to put them as the last entries (by default that is typically right after quiet), just make sure each entry is separated by a space.

2. Rebuild your linux images with new grub configuration:

 grub2-mkconfig -o /boot/grub2/grub.cfg

3. Reboot


Assuming that all goes well, you should now have entries in /sys/class/backlight that you can interface with to adjust the backlight levels. Most utilities that are available to tweak backlight settings (with some major exceptions) interface with the sysfs via the interfaces configure by the ACPI driver, thinkpad_acpi in your case, which is why none of them were working for you. Hopefully with these changes they will work correctly.

This writeup is a bit dated but is accurate for the CentOS 7.x kernel (3.10) and provides detailed info on how to tweak backlight and many other settings with the thinkpad_acpi driver.

  • I'll let you know if this works once in back at my home, thanks so much I think I'll be able to get t with this – spoon_seth Sep 7 '16 at 15:01
  • my backlight directory is unfortunately still empty after these changes. – spoon_seth Sep 7 '16 at 18:18
  • Did you check if the thinkpad_acpi module is loaded? Instructions in answer – Argonauts Sep 7 '16 at 19:28
  • Yes, the module is loaded. This is a little confusing but your answer was helpful still – spoon_seth Sep 7 '16 at 19:30
  • Getting close. Run the following command and post the output. The issue should be noted here. dmesg | grep thinkpad_acpi – Argonauts Sep 7 '16 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.