4

My laptop is Asus K53SV, you can find its specification here. I tried to install Arch Linux with UEFI boot method, and I stuck at a black screen after press Arch Linux archiso x86_64 UEFI CD.

Firstly, I download Arch at its homepage, then I use dd in another laptop running Arch to make a live USB. I has use that usb to install another legacy boot one but when I tried to install UEFI boot in my computer, it stuck.

Here is my bios configuration normal

If I want to boot by usb, normally, it's like this, then I will boot into legacy mode enter image description here

And if I change into this, it will boot in UEFI mode, but with 4 options only (missing Default Interface option)

enter image description here

After pressing Arch Linux archiso x86_64 UEFI CD, I stuck at a black blank screen. I've searched on Google, it seems that I have to press e, then add something like nomodeset.

This link also provide the reason is the integrated graphic card

At the time of this blog post the current version of the nouveau driver does not support the GeForce GTX970M/GTX980M. This will change in the future. Refer to nouveau's feature matrix for the current state of card support.

For this reason it is necessary to disable the auto-loading of the nouveau driver by modern Linux kernels upon boot. Otherwise you will only get a blank screen. To do this, press e in the Arch boot menu and append the following:

nomodeset

This will force Linux to use software graphics rendering instead of using the nouveau driver. Your machine has powerful hardware so you will have no further issues with this during installation.

My question is

1- What is the problem, exactly? When I use this USB to install Arch on a more modern computer, the boot screen has 5 options rather than 4 like mine.

2- Does my laptop have UEFI mainboard? When installing Window 10, it automatically set up an EFI partition, with size 350 Mb.

3- How can I fix that? My graphic cards are Intel HD 3000 and NVidia Geforce GT 540M.

Please help me.

Thanks

EDIT Here is the screenshot of my BIOS's secuirty tab, as GAD3R requested

enter image description here

  • 1
    Go to security tab, secure boot menu then click disabled – GAD3R Sep 6 '16 at 9:06
  • I have no secure boot option in security or other tabs :( – Knumber10 Sep 6 '16 at 9:13
  • 1
    can you add a screenshot of your security Tab? – GAD3R Sep 6 '16 at 9:29
  • @GAD3R Okay, I've posted it :) – Knumber10 Sep 6 '16 at 9:47
  • wiki.archlinux.org/index.php/… from the bios setting go to the exit tab then choose Launch EFI Shell from filesystem device – GAD3R Sep 6 '16 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.