0
  • Initial condition: brightness-control buttons do not work, no animation of brightness-control not seen on actions, but manual control of brightness work in Settings and at the top-bar.
  • Condition after test code 1: brightness-control buttons do not affect brightness but visual animation is shown after reboot; however, now, the manual control of brightness do not work anymore so the solution which works in Ubuntu does not work in Debian.
    • I have tried here both GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=" and GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=" in /etc/default/grub unsuccessfully, where the option without splash is the default setting in Debian, in contrast to Ubuntu. The complete default option is only with quiet in Debian.

Differential solutions

  1. Use defaults. Undo changes of Test code 1. Weakness: brightness keys do not work but you can control brightness from the top-bar.
  2. ?

Test code 1

I can fix the brightness-control buttons (fn+f5, fn+f6 for brightness decrease and increase, respectively) in Ubuntu 16.04 as described in the thread How to Enable Brightness Buttons when acpi_osi of Grub not enough in 16.04 of Zenbook? but not in Debian 8.5. There is no directory /usr/share/xorg.conf.d/ in Debian, in contrast to Ubuntu, so possibly similar work flow does not work in Debian. Main points done in the following work flow in Debian

  1. Add code in /etc/default/grub

    # guillaume-desclaux https://ubuntuforums.org/showthread.php?t=2243162
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="
    # I also tried here without `splash`, since it did 
    # not exist by default in Debian, in contrast to Ubuntu.
    
  2. Create directory /usr/share/xorg.conf.d/

  3. Add the following content in the file /usr/share/xorg.conf.d/20-intel.conf

    # https://askubuntu.com/a/536618/25388
    Section "Device"
            Identifier "card0"
            Driver "intel"
            Option "Backlight" "intel_backlight"
            BusID "PCI:0:2:0"
    EndSection
    
  4. Run as root

    update-grub
    

My work flow in Debian

root@masi:/home/masi# vim /etc/default/grub 
root@masi:/home/masi# vim /usr/share/x
xfig/      xml/       xml-core/  xsessions/ 
root@masi:/home/masi# mkdir /usr/share/xorg.conf.d/
root@masi:/home/masi# vim /usr/share/xorg.conf.d/20-intel.conf
root@masi:/home/masi# sudo update-grub
bash: sudo: command not found
root@masi:/home/masi# update-grub
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-4.6.0-0.bpo.1-amd64
Found initrd image: /boot/initrd.img-4.6.0-0.bpo.1-amd64
Found linux image: /boot/vmlinuz-3.16.0-4-amd64
Found initrd image: /boot/initrd.img-3.16.0-4-amd64
Adding boot menu entry for EFI firmware configuration
done
root@masi:/home/masi#

Output: brightness keys not working after reboot; you now see the visual effect but no effect; after the changes, the brightness control also break if you try to manually change it.

Hardware: Asus Zenbook UX303UA
OS: Debian 8.5 64 bit
Linux kernel 4.6

0

No supported and/or sufficient solution exists for the hardware in Debian 8.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.