4

I installed Lubuntu with QWERTY, and now want to switch it to DVORAK.

The documented way to do this is to use the Keyboard Layout Handler on the panel.

This works, but only during and within a desktop session.

For login, the system still reverts to QWERTY, both initial and for any window lock.

The TTY sessions also default to QWERTY.

Is there any way to change everything to DVORAK?

4

If your system has changed to systemd you should be able to control the global setup with the localectl command. Check the current settings with

$ localectl status

List the possible keyboard variants, including dvorak, with

$ localectl list-x11-keymap-variants

Set the new global keyboard and locale with

$ localectl set-x11-keymap ... 

where you need to give, in order, the layout, model, and variant (dvorak). Use the layout and model got from the status output. See man localectl.

Normally, the set-x11-keymap option is supposed to change the console tty keymap automatically as well. However, if it doesn't do a good enough job, you can explicitly set the console tty keymap eg with

$ localectl --no-convert set-keymap us-dvorak

(Use --no-convert to not disturb the X11 map). Use localectl list-keymaps to see what dvorak names are possible.

  • 1
    Thank you -- that fixed the login! However, my TTYs still default to QWERTY. Any suggestions on how to fix those? Thanks again! – dwrz Sep 4 '16 at 15:23
  • If by tty you mean the full-screen console, then set-x11-keymap is supposed to change that keymap automatically as well. However, perhaps it didnt find a good enough match. You can explicitly set the console tty keymap eg with localectl --no-convert set-keymap us-dvorak. Use localectl list-keymaps to see what dvorak names are possible. – meuh Sep 4 '16 at 15:46
  • Thank you for the follow-up. I just tried this, and the tty's are still stuck on QWERTY. Also, list-keymaps yields "Couldn't find any console keymaps." Bug? – dwrz Sep 5 '16 at 20:23
  • Perhaps systemd is not fully implemented yet, so you should use whatever used to be the method in earlier releases. I'm not familiar with that, but there is a install-keymap command. – meuh Sep 6 '16 at 14:15
  • I was able to execute the command setxkbmap -model pc104 -layout us,us -variant ,dvorak -option grp:alt_shift_toggle using localectl status shows it taking effect, but however, when I press alt and shift key, there is no effect in keyboard layout change, even after logging out, and restart, pressing the toggle key combination has no effect. – Yu Shen Sep 22 '16 at 3:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.