0

My wifi was really slow. I decided to buy a new wifi adapter (archer t8e). It has the BCM4360 chipset. I got it said it was connected using ndiswrapper, but I wasn't able to get websites loaded. The link on wikidev says it should work. What would be the steps I need to proceed to get it working?

⋊> ~ lspci -nn -d 14e4:                                                                          
04:00.0 Network controller [0280]: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)
0

According to Debian-wiki:

Add a non-free component to /etc/apt/sources.list:

deb http://httpredir.debian.org/debian/ jessie main contrib non-free

Install linux-headers and broadcom-sta-dkms packages:

apt-get update
apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms

Unload conflicting modules:

 modprobe -r b44 b43 b43legacy ssb brcmsmac bcma

Load the wl module:

 modprobe wl

Edit

Turn off the power management:

iwconfig wlan0 power off

To make it permanent create a new file under /etc/pm/config.d:

nano /etc/pm/config.d/power_off

With the following contents:

#!/bin/sh
/sbin/iwconfig wlan0 power off

save and make it executable chmod +x /etc/pm/config.d/power_off then reboot

| improve this answer | |
  • runiwconfig wlan0 power off – GAD3R Sep 3 '16 at 21:26
  • 1
    could you also add how to make this permanent. (with modprobe.d) – Tristan Sep 4 '16 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.