1

I'm trying to build some software from scratch on a full installation of Slackware64 14.2. I follow the instructions in readme

 ./autogen.sh # only needed if building from git repo
 CFLAGS="-march=native" ./configure
# Use -march=native if building for a single machine
make

I cloned it from git then did issued autogen, which outputed:

configure.ac:16: installing './compile'
configure.ac:4: installing './config.guess'
configure.ac:4: installing './config.sub'
configure.ac:6: installing './install-sh'
configure.ac:6: installing './missing'
Makefile.am: installing './depcomp'

Then after that I issued the next command as I build it on a single machine but it resulted in an error:

checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `/home/xtd8865/data/builds/mine/cpuminer-multi/cpuminer-multi':
configure: error: C compiler cannot create executables
See `config.log' for more details

As I said, it's a full slackware version:

gcc -v
Reading specs from /usr/lib64/gcc/x86_64-slackware-linux/5.3.0/specs
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-slackware-linux/5.3.0/lto-wrapper
Target: x86_64-slackware-linux
Configured with: ../gcc-5.3.0/configure --prefix=/usr --libdir=/usr/lib64 --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-bootstrap --enable-languages=ada,c,c++,fortran,go,java,lto,objc --enable-threads=posix --enable-checking=release --enable-objc-gc --with-system-zlib --with-python-dir=/lib64/python2.7/site-packages --enable-libstdcxx-dual-abi --with-default-libstdcxx-abi=gcc4-compatible --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --enable-lto --disable-install-libiberty --with-gnu-ld --verbose --enable-java-home --with-java-home=/usr/lib64/jvm/jre --with-jvm-root-dir=/usr/lib64/jvm --with-jvm-jar-dir=/usr/lib64/jvm/jvm-exports --with-arch-directory=amd64 --with-antlr-jar=/root/slackware64-current/source/d/gcc/antlr-runtime-3.4.jar --enable-java-awt=gtk --disable-gtktest --disable-multilib --target=x86_64-slackware-linux --build=x86_64-slackware-linux --host=x86_64-slackware-linux
Thread model: posix
gcc version 5.3.0 (GCC) 

So I'm not sure why it cannot create executables. I issued those commands as standard user (tried as root as well but no luck either). Why is it failing?

The output of the config.log is here http://pastebin.com/QUqHW6zQ

Thank you

1

The error is in this line:

ac_cv_env_CFLAGS_value='*-march-native*'

which for whatever reason contains wildcards. The log does not show an earlier use than its attempt to use it in gcc, so:

  • either there is a scripting error in what you downloaded or
  • you have an environment variable setting which is confusing the script.

To see a scripting error, you'd have to turn on the shell trace (adding a set -x after the first line) and (it goes to the standard error) capture the output and read a much longer log...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.