9

I juste made a clean install of the last Kali (not the light one) on my TP300 Full disk and encrypted

Then I updated everything and added Linux headers (I'm not a pro at all with Linux), installed my WiFi driver... and then noticed that I have no sound card in my settings, no sound icon in the control panel, and... no sound ! My sound keys don't work.

I never had this problem with older versions..

I tried a lot of command found on the net but nothing, I think my pc detect the sound card because I think I saw it several times using commands to display cards etc.. And before login, I can play with the volume, I hear the sound, I see the sound icon, and the key works, but after login.. nothing !

Do someone have an idea to fix this ?

3
  • I get all back when I enter the "pulseaudio" command, but I need to do it each time I boot, trying to find a fix... why so many problems with linux lol.... – Mike Sep 4 '16 at 13:24
  • the link here worked for me bugs.kali.org/view.php?id=3529 . worth checking out – user188653 Sep 7 '16 at 8:00
  • Audio is working for all other users but not for root – nikhil mehta Sep 24 '16 at 10:10
10

To fix the problem, type this in the terminal;

systemctl --user enable pulseaudio

This changes a configuration file to enable pulseaudio starting on boot.

Reference: https://bugs.kali.org/view.php?id=3128

4

If you are using Kali under a VM, such as VirtualBox, then don't try to change anything by installing another sound processor! First try to change the VM sound card settings. For example, using a Windows host with Kali guest, latest update. You will find that Intel HD Audio is not supported in Kali (out-of-the-box). So make sure you have the following VM settings:

Host Driver:   Windows DirecSound
Controller:    ICH AC97

If there is still no sound on startup, run the following:

systemctl --user enable pulseaudio && systemctl --user start pulseaudio

Check success with:

systemctl --user status pulseaudio

If still no success, you may need to reboot.

Whatever, you do, don't randomly try to apt-get purge <*pulseaudio> because you may inadvertently remove some Kali features.

2
  • An anonymous user tried to add: "Or if you are getting condition failed message with ConditionUser =!root was not met. Then run following command nano /usr/lib/systemd/user/pulseaudio.service and change ConditionUser = !root into ConditionUser = root, it worked for me." – not2qubit Jan 25 '18 at 16:38
  • If you are still having problems with *nix sound, please see my post at RPi SE for an in-depth how-to on using sound on *nix based distros. – not2qubit Dec 24 '20 at 20:54
4

To fix the problem;

  1. Open Terminal (Ctrl + Alt + T)
  2. Now type sudo gedit /etc/pulse/daemon.conf
  3. Scroll down to find ;daemonize = no
  4. Remove the ; (as mentioned by @not2qubit)
  5. Replace daemonize = no with daemonize = yes

That should fix it!

1
  • 1
    Attention: In that file all the lines are commented out with a ;, so remove that in front first. – not2qubit Jun 2 '17 at 21:21
-1

https://www.youtube.com/watch?v=JPTzVcBYVE8

Run lspci in a terminal to get your audio device name. Then run sudo apt-get install libasound2 alsa-utils alsa-oss. After installing, open alsamixer. If any of the channels are muted it will say MM; navigate to those channels and press m to unmute.

2
-1

In a terminal run pulseaudio -D. That would most likely fix your issue.

Pulseaudio wouldn't work with root! To run it at startup, you need to create a new user and login with those user credentials.

1
  • You should correct this. Pulseaudio can run as root – David Kariuki Dec 24 '20 at 20:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.