0

Situation: to improve the power management of the zenbook when I need computation power, especially when the zenbook is in AC
I am experimenting about 3 hour battery life without any computation, without any firmware failures/issues and just typing in Stackexchange network in my new UX303UA. Expected battery time is up to 7 hours, here its Asus website. Arch Linux wiki confirms in the same series ultrabook

Battery has a design capacity of 4429mAh, and is able to provide just over 3 hours of autonomy under normal circumstances (average load of around 0.3 and WiFi enabled, brightness lowered to mid-range) without serious power saving tweaks. - - ACPI tools are able to correctly detect the battery state.

They recommend Laptop mode tools, which I will be testing

  1. apt-get install laptop-mode-tools
  2. Enable laptop-mode.service, where the following command should return 2

    cat /proc/sys/vm/laptop_mode
    
  3. Actually, I do not understand why they propose to change to the laptop mode to 1 where I would like to keep 0 when in AC because I need power in computations

    # http://askubuntu.com/questions/180712/how-to-enable-laptop-mode
    # edit /etc/laptop-mode/laptop-mode.conf`       
    ENABLE_LAPTOP_MODE_ON_AC=1 
    # where I want to have zero. Why they propose 1?
    
  4. Restart laptop-mode as root by /etc/init.d/laptop-mode restart

Default power saving states found by grep -command

root@masi:/home/masi# grep -r '^\(CONTROL\|ENABLE\)_' /etc/laptop-mode/conf.d/etc/laptop-mode/conf.d/intel-sata-powermgmt.conf:CONTROL_INTEL_SATA_POWER="auto"
/etc/laptop-mode/conf.d/radeon-dpm.conf:CONTROL_RADEON_DPM="auto"
/etc/laptop-mode/conf.d/sched-smt-power-savings.conf:CONTROL_SCHED_SMT_POWER_SAVINGS="auto"
/etc/laptop-mode/conf.d/start-stop-programs.conf:CONTROL_START_STOP=1
/etc/laptop-mode/conf.d/wireless-power.conf:CONTROL_WIRELESS_POWER_SAVING="auto"
/etc/laptop-mode/conf.d/intel_pstate.conf:CONTROL_INTEL_PSTATE="auto"
/etc/laptop-mode/conf.d/dpms-standby.conf:CONTROL_DPMS_STANDBY="auto"
/etc/laptop-mode/conf.d/nmi-watchdog.conf:CONTROL_NMI_WATCHDOG="auto"
/etc/laptop-mode/conf.d/sched-mc-power-savings.conf:CONTROL_SCHED_MC_POWER_SAVINGS="auto"
/etc/laptop-mode/conf.d/intel-hda-powersave.conf:CONTROL_INTEL_HDA_POWER="auto"
/etc/laptop-mode/conf.d/pcie-aspm.conf:CONTROL_PCIE_ASPM="auto"
/etc/laptop-mode/conf.d/auto-hibernate.conf:ENABLE_AUTO_HIBERNATION=0
/etc/laptop-mode/conf.d/wireless-iwl-power.conf:CONTROL_IWL_POWER="auto"
/etc/laptop-mode/conf.d/exec-commands.conf:CONTROL_EXEC_COMMANDS="auto"
/etc/laptop-mode/conf.d/hal-polling.conf:CONTROL_HAL_POLLING="auto"
/etc/laptop-mode/conf.d/ethernet.conf:CONTROL_ETHERNET="auto"
/etc/laptop-mode/conf.d/runtime-pm.conf:CONTROL_RUNTIME_AUTOSUSPEND=1
/etc/laptop-mode/conf.d/configuration-file-control.conf:CONTROL_CONFIG_FILES=0
/etc/laptop-mode/conf.d/ac97-powersave.conf:CONTROL_AC97_POWER="auto"
/etc/laptop-mode/conf.d/eee-superhe.conf:CONTROL_SUPERHE="auto"
/etc/laptop-mode/conf.d/lcd-brightness.conf:CONTROL_BRIGHTNESS=0
/etc/laptop-mode/conf.d/terminal-blanking.conf:CONTROL_TERMINAL="auto"
/etc/laptop-mode/conf.d/bluetooth.conf:CONTROL_BLUETOOTH=0
/etc/laptop-mode/conf.d/cpufreq.conf:CONTROL_CPU_FREQUENCY="auto"
/etc/laptop-mode/conf.d/cpufreq.conf:CONTROL_CPU_THROTTLING=0
/etc/laptop-mode/conf.d/wireless-ipw-power.conf:CONTROL_IPW_POWER="auto"
/etc/laptop-mode/conf.d/video-out.conf:CONTROL_VIDEO_OUTPUTS=0
/etc/laptop-mode/conf.d/battery-level-polling.conf:ENABLE_BATTERY_LEVEL_POLLING=0

I am not sure which files are relevant in the power management in the directory etc/laptop-mode/conf.d/, etc many authors ignore ac97-powersave.conf - - why?

Iterating GAD3R's answer

Installing the package (apt-get install laptop-mode-tools), rebooting and having just the default power options leads to significant increase in battery time. The 25% of battery is now about 2h 15 minutes -use so 100% of battery is about 10 hours of use i.e. about 3.5 times more battery time. There are only a few options off in the settings' file where I cannot find anything relevant to turn on

root@masi:/home/masi# grep =0 /etc/laptop-mode/laptop-mode.conf
#    CONTROL_something=0/1   Determines whether Laptop Mode Tools controls 
VERBOSE_OUTPUT=0
DEBUG=0
ENABLE_LAPTOP_MODE_ON_AC=0
ENABLE_LAPTOP_MODE_WHEN_LID_CLOSED=0
DISABLE_BATTERY_ALARM_CHECK=0
CONTROL_NOATIME=0
CONTROL_HD_WRITECACHE=0
NOLM_BATT_HD_WRITECACHE=0
LM_HD_WRITECACHE=0

I do not want to change defaults much. Which settings would you change to accomplish the significant improvement in the power management?

Hardware: Asus Zenbook UX303UA
OS: Debian 8.5 64 bit
Firmwares: updated and/or installed as described in the thread How Smooth is Upgrading Linux kernel in Debian 8.5?
Linux kernel: 4.6 of backports
Related: ASUS Zenbook UX303 in Arch Linux
Other Asus Zenbooks of 2nd gen: UX301LA

1 Answer 1

1

To improve Power Management on your Laptop enable all feature of LMT from /etc/laptop-mode/laptop-mode.conf or using the GUI by runing:gksu lmt-config-gui

many authors ignore ac97-powersave.conf - - why?

This feature is useful , only if you have AC97 sound card, you can enable it form ac97-powersave.conf file:

nano /etc/laptop-mode/conf.d/ac97-powersave.conf

set the value as bellow :

# Control AC97 audio chipset power?
CONTROL_AC97_POWER=1
1
  • 1
    I think the default configurations are great. They already increased my battery time significantly: 25% of battery corresponds to 2h 15 minutes of use i.e. means about 10 hours battery time with 100% of battery. - - I did not find any option besides the defaults which I would more turn on in the file /etc/laptop-mode/laptop-mode.conf. Did you? - - Please, see the body about parameters which are off by default there. Sep 3, 2016 at 13:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .