I just booted Kali Linux from a USB, on a Mac computer. Unfortunately, I am not connected to the Internet.

In the systems menu topbar, there is no Wifi button as I have seen in the Help app. Instead, there is a proxy button. Ifconfig tells me I'm not connected to anything, and I also receive the following error message: "wlan0: error fetching interface information: Device not found"

/var/log/kern.log: permission denied

dmesg | grep wlan0: makes no result, just skips to the next line

dpkg -i <dkmspackage>.deb: dependency problems prevent configuration

Result of lspci -knn | grep Net -A2

Result of lspci -nn

Result of dpkg dkms

  • 1
    We really need more information to help you, namely a tool like lspci or lsusb, and some kernel output, dmesg | grep wlan0 – eyoung100 Sep 6 '16 at 15:38
  • 1
    What is the output of lspci -knn | grep Net -A2 ? – GAD3R Sep 8 '16 at 15:11
  • As a side note, never post pictures of text. Just copy the text and paste it as a formatted block. – John Leuenhagen Sep 11 '16 at 15:47
  • I noticed that I was awarded a bounty from this question, but I don't feel like it quite answered your question, I also noticed that user: 'ajlowndes' posted the list of packages that you need to get this to work. Also, a sidenote - you don't execute the *.log files like you did because you will get the permission error (by default log files are non-executable for obvious reasons - there's nothing to execute). Instead try something like "nano full-path-to-your-log-file.log" ('nano' being a commandline text editor that ships with Debian) ... on Kali linux you should probably try "vi" instead – Kārlis K. Sep 19 '16 at 16:02
  • I've looked in other places, and it appears that there is a fundamental incompatibility between my wireless card and the distro. I'm using a different computer. – Megalonychidae Sep 21 '16 at 12:36

Can't comment yet, so I'm forced to write this as an answer but based on my experience with Linux and Wi-Fi... you're probably missing a firmware package, so the default configuration didn't pick up on your adapter.

They have specified a couple troubleshooting steps on their website too (have you tried following them?): http://docs.kali.org/installation/troubleshooting-wireless-driver-issues

You should check if there are any errors concerning firmware in your Kernel logs, on Debian this would be in:


On Kali Linux this could be somewhere else or under a different filename (haven't used or tried Kali linux but it's based off of Debian).

Also, you can try and see what network adapters are recognized:

lspci -nn

and since Kali Linux is based off from Debian and uses Stretch packages(as it seems according to my findings), then on a PC that's connected to the internet, search for the missing firmware and download their packages off from https://packages.debian.org/stretch/kernel/... then get the firmware package copied on to the PC with Kali Linux and run:

dpkg -i <DEB_PACKAGE>.deb

to install it.

UPDATE: See THIS POST below for the exact packages that you need to download.


You have a Broadcom BCM4360 WiFi chipset (14e4:43a0, rev 03), which, though a bcm43xx chipset, isn't handled by the b43 driver; the non-free wl is offered instead, and seems to be the only driver that supports the 14e4:43a0 (see here).

It's packaged for Debian Jessie as broadcom-sta-dkms (see here), and I believe it's under that name in Kali's kali-rolling repository as well. I suggest you try:

$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install broadcom-sta-dkms

After installing it, you'll need to unload any conflicting drivers you have loaded (check with lsmod):

$ sudo modprobe -r b44 b43 b43legacy ssb brcmsmac bcma     # ... and/or any others

Then load wl with a sudo modprobe wl.

  • This doesn't work, but I appreciate the help, so +1. – Megalonychidae Sep 10 '16 at 10:27
  • Where does it fail? I had a similar issue some time ago and would be happy to try and help more! – charliegreen Sep 10 '16 at 18:36

I had the exact same issue.

Because you can't access the wifi, you likely don't have internet access while in Kali at all. I solved this issue by downloading the following list of files in OSX and saving them to a USB drive:

And the following three from here:

  • linux-compiler-gcc-5-x86_4.*.*-5kali1_amd64.deb
  • linux-headers-4.*.*-kali1-amd64_4.*.*-1kali1_amd64.deb
  • linux-kbuild-4.*_4.*.*-2kali1_amd64.deb

    where .* is the matching kernel value of your system - which you can find with: uname -r in kali.

Once you have them on the USB and have booted into Kali, you need to install the dependencies before the broadcom driver... so cd into your usb directory (or copy them to desktop and cd to there), then run dpkg -i [package] firstly on the dkms package, then the three "linux-" ones (can't remember what order), then finally the broadcom one.

As soon as the Broadcom one is installed, you should see the wifi icon in the top right suddenly start working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.