0

In FreeBSD, similar to Linux, a FAT32 formatted external volume (da0) is mounted by root with:

mount -t msdosfs /dev/da0 /media/usb

But all files and directories in /media/usb/ now have the permission and ownership

-rwxr-xr-x  1 root  wheel

In Linux this can easily be changed by using the option umask, for example as described in this answer.

But the mount coming with FreeBSD (10.3) seems not to have that option...?

How can one achieve a similar effect in FreeBSD with a missing umask option?

2

You can do it like this:

mount -t msdosfs -m 644 -M  755 /dev/da0 /media/usb

See man mount_msdosfs for more details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.