4

I've turned bluetooth on, both on Bluetooth Settings and hardware (button) so that Settings dialog box told that the files received via bluetooth will be placed in Downloads. I've paired my Android device with my laptop. I've turned the Sharing Settings on (however there is no such a "bluetooth sharing" there). I've installed gnome-user-share. I've tried with blueman (and it was failed). I even have done this (actually it was success when I used Ubuntu long time ago; however it's not working on Fedora 24).

Is there anyway to solve the problem or at least inspect the exact problem (such as from log)? The Android phone I use to send the file simply stated "Connection unsuccessful". However the Settings in Android phone stated that it was connected.

Screenshots

Bluetooth Settings

Sharing Settings

Android Bluetooth Settings

Android Transfer failed

7

I've just done it on Fedora 24 using blueman-manager. First, when in blueman remove the device from the known devices. Repeat the search and when your device appears run the setup. Select "connect to audio source" (it didn't matter to me).

Based on this you need to enable obex (obexd is a dependency of blueman).

systemctl --user start obex
sudo systemctl --global enable obex

After that you'll be able to send files both ways.

enter image description here

  • 1
    It works without blueman. Actually I don't like to install additional software, so I just try your suggestion without installing it. I just remove the known device from both my laptop and my phone and systemctl --user start obex. Thanks – fikr4n Sep 6 '16 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.