1

Condition: unstable caret-cursor and its position
Other complications: many enter-artifacts, much lost content because sudden selections of contents and overwrites, often ctrl+z does not work etc in Google Product Forums so much lost work time; my typing speed in Debian now: 10-30 WPM; normally, 80-95 WPM long-term with Dvorak

  • configurating Keyboard > Typing in Fig. 1 cannot solve the artifacts so there must be something internal going on; possible related to, touchpad/...
  • keybooard-layout independent - occurs in Qwerty and Dvorak
  • no firmware errors - dmesg |grep firmware returns no relevant errors/warnings
  • keyboard-independent - problems occur with an external keyboard too

I had to do about two corrections every sentence because of abnormal typing configuration. I think I am not touching the touchpad neither by accident. I think I have much more typing artifacts now than with Ubuntu 16.04.

Fig. 1 Options which I change to find optimal configuration but not sufficient and something internal must be going on

enter image description here

System characteristics

  1. I purged already xserver-xorg-video-intel because many bugs so using modesetting and (2)
  2. Backported Linux kernel (4.6) and Skylake CPU support and firmware installed (thread How Smooth is Upgrading Linux kernel in Debian 8.5?)

    • apt-get -t jessie-backports install linux-image-amd64
    • apt-get -t jessie-backports install firmware-misc-nonfree
  3. Installed wifi firmware

    • apt-get -t jessie-backports install firmware-iwlwifi

Proposals

  1. Some missing firmware because no firmware errors, severe problem and the setting Keyboard > Typing
  2. Insufficient Skylake support in Linux kernel 4.6? I will exclude this thing by trying 4.7. - - I think CPU graphic can affect cursor's location, which stability seems to be the main problem here.

Hardware: Asus Zenbook UX303UA
Debian: 8.5 64 bit
Linux kernel: 4.6 backported
Keyboard layout: Qwerty, Dvorak, ...

0

Fig. 1 Disable touchpad while typing, Fig. 2 Keyboard > Typing settings, Fig. 3 Disable long-key presses, Fig. 4 Better long-term WPM by using Fig. 3's option

enter image description here enter image description here enter image description here enter image description here

I think the problem is mainly caused by the over-sensitive touchpad, which causes the cursor's position change much. I did the following change i.e. disable touchpad, while typing, and it resolves the problem significantly in Fig. 1. Then, there is the problem of having long-presses by accident when typing fast, so I think disabling Key presses repeat when key is held down is the best option here in Fig. 3, but Fig. 2 is also optional but there you should be able to calibrate long-presses individually, which is not possible by defaults, extended in the thread How to Have key-repeats of Arrow keys when disabled key-repeats? for arrow-keys.

How to Calibrate your Typing Speed?

I play play.typeracer.com, where I found one good condition with the settings in Fig. 2, but later I find Fig. 3's option better because long-presses cause much problems etc when making typing mistakes. I can reach about 10% greater WPM by disabling long-presses in Fig. 4. Other changes needed in my tying

  • Use to alleviate no-long-presses for removing a word and undoing, respectively, ctrl+backspace/z.
  • Use ctrl+arrow key in moving. It would be great to still have long-presses of arrow-keys although you have disabled the main option, because it is the mainly feature needed for repositioning the caret position, extended in the thread How to Have key-repeats of Arrow keys when disabled key-repeats?

Differential solutions

  1. Is there a way to have it so that key repeats aren't disabled but only start after you've held a key down for a longer time? (Random832)

Conclusion

  • I still get some center-artifacts and unstable cursor position about 1/40 of times, so significantly less than two times per sentence. So it is likely that the cause of the bug/issue is still existing in the system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.