3

I'm trying to change my MAC address using macchanger but it seems as if my device is not able to spoof a different address? I don't know but it seems as if no where has a solution to this.

root@kali:~# sudo macchanger -a wlan0                                                                                                                              
Current MAC:   XX:XX:XX:XX:XX:XX (Apple)
Permanent MAC: XX:XX:XX:XX:XX:XX (Apple)
[ERROR] Could not change MAC: interface up or insufficient permissions: Too many open files in system
root@kali:~# 

What does this mean? 'interface up or insufficient permissions'. I've tried this:

sudo ifconfig wlan0 down
sudo macchanger -a wlan0
sudo service network-manager restart

But I still get that error on the second command.

FYI:

root@kali:~# lspci | grep Wireless
03:00.0 Network controller: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter (rev 03)
root@kali:~# 
3
  • 1
    As a comment and not an answer, but not all hardware allows setting the mac address.
    – coteyr
    Sep 1, 2016 at 17:49
  • How can I be sure that this is the problem? Is there a way to check whether my hardware can spoof? Also what is the alternative then if I need to change my MAC address? Sep 1, 2016 at 18:02
  • The hardware is not the problem because I just tried it on OS X and it worked Sep 3, 2016 at 21:47

1 Answer 1

2

To change the MAC adress of the wlan0 interface, run the following commands:

ifconfig wlan0 down
ifconfig wlan0 hw ether XX:XX:XX:XX:XX:XX
ifconfig wlan0 up

Verify:

ifconfig wlan0 |grep HWadd

Edit

Edit the 70-persistent-net.rules configuration file:

 nano /etc/udev/rules.d/70-persistent-net.rules

Change the MAC adress:

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="xx:xx:xx:xx:xx:xx", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

Replace xx:xx:xx:xx:xx:xx then reboot your machine.

edit2

Using iproute2 Methode:

ip link set dev wlan0 down
ip link set dev wlan0 address XX:XX:XX:XX:XX:XX
ip link set dev wlan0 up
8
  • SIOCSIFHWADDR: Too many open files in system Sep 1, 2016 at 18:31
  • Even after running: ulimit -n 4096 Sep 1, 2016 at 19:17
  • root@kali:/etc/udev/rules.d# ls 70-persistent-cd.rules 73-usb-net-by-mac.rules Sep 1, 2016 at 19:42
  • 1
    and 70-persistent-cd.rules is empty. 73-usb-net-by-mac.rules is a bash file Sep 1, 2016 at 19:43
  • try systemd-udevd wiki.archlinux.org/index.php/MAC_address_spoofing
    – GAD3R
    Sep 1, 2016 at 19:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .