1

I installed fcitx-googlepinyin and texmaker in Ubuntu LTS 16.04 using apt-get install command. However, I cannot switch to googlepinyin in texmaker's editor. As a result, I cannot type Chinese with fcitx system in texmaker, while such a problem does not occur when I type Chinese at other places (e.g. gedit and terminal).

1

I had the same problem using fcitx in texstudio. I fixed it for the moment by launching it from the terminal like so:

QT_IM_MODULE=fcitx texstudio

Will check back in and edit if I can figure out how to make it automatic.

  • Glad to help! Let me know if you manage to figure out how to make it automatic before I do. – pandahats Jan 6 '17 at 4:37
0

If you want to automate the process described by pandahats, you can add the following lines into your startup scripts:

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx

For example: .xprofile for desktop environment or .xinitrc otherwise. I personally use .xinitrc since I use i3.

If you still can't fix it, you can try execute "qtconfig-qt4" and find the default input method option on the third tab.

For more information, please refer to:

https://wiki.archlinux.org/index.php/fcitx#Non_desktop_environment

Regards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.