1

I need to install the driver as it was not recognised automatically when installing Kali Linux on my MacBook Pro. If I type iwconfig then I get only lo and no wlan0. There is no ethernet port on the new MacBooks so I needed to find a way to connect to the internet in order to download stuff without using the USB method. I used my phone's connection over Bluetooth.

The following terminal command gives me the Wireless Network Adapter make. I went to kernel.org and looked this up in the Drivers table. It shows that it wasn't supported and I needed to use something called wl.

root@kali:~# lspci -knn | grep Net -A2
03:00.0 Network controller [0280]: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)
Subsystem: Apple Inc. BCM4360 802.11ac Wireless Network Adapter [106b:0134]
Kernel modules: bcma
04:00.0 Multimedia controller [0480]: Broadcom Corporation 720p FaceTime HD Camera [14e4:1570]

I am having trouble configuring my network card in my MacBook Pro to work on Kali Linux. When I try:

apt-get install broadcom-sta-dkms

I get the error:

Error! Bad return status for module build on kernel: 4.6.0-kali1-amd64 (x86_64)
Consult /var/lib/dkms/broadcom-sta/6.30.223.248/build/make.log for more information.

The other problem some people are having is with:

modprobe wl
  • Please add the output of apt-cache search linux-headers – GAD3R Sep 1 '16 at 9:55
  • 1
    Sure. I've done that and I get the multiple options. I tried installing the first one but got an error message (see discussion please). Thank you for helping – user3573987 Sep 1 '16 at 12:09
1

I eventually fixed this by doing the following:

1) Making sure these were in /etc/apt/sources.list

deb http://http.kali.org/kali kali-rolling main contrib non-free
# For source package access, uncomment the following line
deb-src http://http.kali.org/kali kali-rolling main contrib non-free

2) Making sure everything was ready

apt-get update && apt-get dist-upgrade

3) Rebooting the kernel

reboot

4) Finding out my version:

root@kali:~# uname -a
Linux kali 4.6.0-kali1-amd64 #1 SMP Debian 4.6.4-1kali1 (2016-07-21) x86_64 GNU/Linux

5) Finding out which network card I had

root@kali:~# lspci | grep Wireless
03:00.0 Network controller: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter (rev 03)

6) Running this:

root@kali:~# apt-get update; apt-get install broadcom-sta-dkms; apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms

7) Then:

root@kali:~# modprobe -r b44 b43 b43legacy ssb brcmsmac bcma

and

root@kali:~# sudo modprobe wl

Finally you can check that it's worked by using iwconfig and you should see that now you have wlan0 recognised by Kali Linux. Go to settings and connect to wi-fi.

protected by Community Nov 18 '17 at 5:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.