1

I'm getting the following error message:

Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/mapper/veracrypt8': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

I'm aware that this problem has something to do with Windows' hibernation/fast startup, and is similar to this question and answer: https://askubuntu.com/questions/145902/unable-to-mount-windows-ntfs-filesystem-due-to-hibernation/. However, I've already tried those solutions, and have had no success. I can mount the partition just fine in Windows, and I can mount it in read-only mode in Linux.

I have Windows 10 and Linux Mint 18 installed. The partition in question does not have an operating system on it, and is the only partition on its disk.

What I've tried:

  • Disabling Fast Startup in Windows
  • Mounting the partition in Windows, then triggering a reboot from Windows and going into Linux instead of back into Windows
  • Checking that there are no Windows page files set up on the partition.
  • Disabling hibernation in Windows with powercfg /h off.
  • Checking that there is no hiberfile.sys on the partition (both from Windows with system files shown and from Linux in read-only mode).
  • Telling Veracrypt in Linux to use -t ntfs-3g -o remove_hiberfile as its mount options.
  • Unlocking (but not mounting) the partition with Veracrypt in Linux, then trying the command sudo mount -t ntfs-3g -o remove_hiberfile /dev/mapper/veracrypt8 /media/veracrypt8.

I originally asked this question on Super User but got no responses, so I'm reposting here. Any suggestions are appreciated!

  • What happens when you mount and immediately unmount the partition in Windows? – maxf Sep 1 '16 at 9:03
  • For future reference, I did get an answer on the original post, here. – PunctualEmoticon Oct 7 '16 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.