1

I am trying to add extend my desktop across multiple monitors, but when I go into Display it only shows one monitor (my Nvidia 970 with 640x480 resolution). However when I do inxi -Gx I see both graphics cards. Any idea how to get screen on all three monitors?

king@king-MS-7640 ~ $ inxi -Gx
Graphics:  Card-1: NVIDIA Device 13c2 bus-ID: 01:00.0
           Card-2: Advanced Micro Devices [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]
           bus-ID: 02:00.0
           Display Server: X.Org 1.17.1 driver: nvidia
           Resolution: 640x480@59.9hz
           GLX Renderer: GeForce GTX 970/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 367.44 Direct Rendering: Yes

If needed my install process for the 970 was:

#physically unplug nvidia 970
#reinstall mint 17.3
add launchpad ppa
apt-get update
sudo apt-get install nvidia-367
sudo reboot
#reconnect the disconnected 970
#fails to launch xserver
sudo nvidia-xconfig
sudo reboot

I have two monitors connected (via DVI splitter) to the Radeon, and 1 monitor connected (via DVI) to the Geforce 970.

0
+100

Back to basics:

Your graphics cards are driven by the X Server. The X server tries to automatically configure itself to use the available hardware, but sometimes this does not work (or does not work in the way you want it). In this case, you need to configure the X server via the xorg.conf file (see here for locations on Ubuntu, on my Debian system I put it into /etc/X11/xorg.conf, which is the "traditional" location).

An additional complication is that the nvidia driver is closed source, and sometimes does not play nice with the rest of the X drivers.

A second complication is that the open source radeon driver conflicts with the proprietary fglrx driver, so you should remove all packages with "fglrx" in it if you have installed it.

All other software works on a level above this. So even if there is some software that allows you to configure everything through a nice GUI, if something goes wrong, you still need to go back to this level to figure out how to fix it.

1) The first thing to do when trying to debug the configuration of the X server is to look at the log file. On my system, the log file is in /var/log/Xorg.0.log, "0" meaning the first X server (usually there is only one, but one can start several servers). The log file will tell you what drivers X tried to load, what the drivers did to initialize the cards, and if something went wrong, what went wrong and why.

So have a look at this file. If it mentions your AMD card, but there's some kind of error, you know what to look for next. If it doesn't mention the AMD card at all, then it decided by default to use only the first card, so we need an xorg.conf.

Evertyime you make changes to the xorg.conf and restart the server, have a look at the log file again to verify what works and what doesn't.

2) The X server is started by the display manager. The display manager for the Gnome Desktop is called gdm, the display manager for KDE is called kdm. Restart these from a console login to restart the X server (faster than reboot).

Your Ubuntu probably uses systemd (which I don't use), but it should be something similar to systemctl restart gdm.service or systemctrl restart kdm.service.

3) If you stop the display manager (systemctrl stop instead of restart, or boot into recovery mode), you can use X -configure to have X create a config file for you that corresponds to the default configuration. It's not strictly necessary to do that, but it will give you an idea how the config file is structured and how the various sections will look like for your hardware.

4) The most important sections you'll need in the xorg.conf file are two device sections, one for each card. They should look something like

Section "Device"
    Identifier  "NVIDIA Card"
    Driver      "nvidia"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
    Identifier  "AMD Card"
    Driver      "radeon"
    BusID       "PCI:2:0:0"
EndSection

This is very likely already enough, the other sections shouldn't be necessary and the defaults for those section should work. You may need a ServerLayout section if the monitors are not layout in the way you want.

If it doesn't work, have a look at the log file and try to figure out what went wrong, and change the xorg.conf accordingly. This is a process, and I can't describe it step by step, because I also need to see the log file to see what to do next.

The format of the xorg.conf file together with available options is also documented in the man pages: man xorg.conf, man nvidia, man radeon.

Related questions:

0

If this is a new setup, ensure at least one of your monitors is using the DP port on the display card. Use only "active" adapters if you are using an adapter for the port connection. This is an absolute requirement. ACTIVE DISPLAY PORT.

Next, follow AMD recommendations to "REMOVE ALL PREVIOUS DRIVERS". Then for good measure, hunt for file names dealing with AMD Video...delete/delete/delete, just be careful not to delete motherboard AMD standard drivers for chipset information.

Next, ensure all of your monitors in the eyefinity display group, are turned on. Unplug any monitors not being used as part of your display group from the graphic card.

Install new driver package (full AMD package for your card). Reboot 2X for good measure.

Go into AMD's application and configure the "eyefinity" grouping save/reboot to ensure it took.

Remember, if you need to add additional monitors (not part of the eyefinity grouping) in an uneven display configuration, you will use the "motherboards" display properties tool to change the configuration of those "additional" monitors. If you do not have additional monitors, disregard the use of the standard monitor properties that your mobo uses (non AMD eyefinity properties)

Lastly, and sort of a logical conclusion...Ensure you are using AMD's video properties for the eyefinity grouping and NOT the motherboard video drivers used to support built in video on the CPU.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.