7

I've installed Linux Mint 18 on my machine, but it has a Radeon HD Graphics card, which is not supported by AMD on systems based on Ubuntu 16.04 (according to some research I did).

So, after the install the system was booting into a black screen and wouldn't go anywhere.

I did some research and found that I could edit the grub boot commands and add radeon.modeset=0. That worked, but I don't know what that does.

Is it ok to run permanently with this parameters?

Does this lower my overall machine performance? I don't really care about graphics, I just use my machine to ordinary stuff.

Thanks, guys.

2
  • What GPU do you have?
    – maxf
    Commented Sep 1, 2016 at 9:18
  • I believe its Radeon HD 7560D, I dont have my pc right noe Commented Sep 1, 2016 at 10:25

1 Answer 1

7
+50

The xxx.modeset=0 disables kernel mode setting for the hardware. In other words, this option tells Linux not to try activating and using the incompatible hardware, which is likely the source of your problems. When this is used, your computer will still be functional, but without the benefits of hardware acceleration provided by the graphics card. This will only affect you when you use graphics-intensive programs such as complex, high-end games. Otherwise it's just fine.

2
  • Will this also reduce power consumption in laptops with discrete graphics like Nvidia which is well supported by Ubuntu?
    – Shiva
    Commented Oct 12, 2019 at 14:33
  • 1
    As an inverse, I got ubuntu to recognize my AMD Radeon on my MacBook Pro 16inch by setting radeon.modeset=1 in the grub settings, it worked great on reboot without any extra installations.
    – james-see
    Commented Jul 20, 2020 at 2:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .