1

I am trying to install Linux Debian 8.5 (dd'ed it successfully to USB stick) on SD card of Zenbook UX303UA. However, Grub is 1 version. I cannot boot from the USB and there exists no menu option for the fetaure in the ultrabook. I accessed the Bios by pressing esc at the login, since it does not start naturally by USB and does not give me a list boot options. I think the USB is at /dev/sdb1 now so one option is to configure Grub directly. Fig. 1 Bios and Boot, Fig. 2 Bios, USB configuration and Advanced

enter image description here enter image description here

Iterating GAD3R's proposal

Disable successfully Fastboot in Bios Boot. Fig. 4 After pressing Esc at login when Fastboot disabled*,

enter image description here

Fig. (5-7) are about unsuccessfully setting up boot by USB

  1. first rename the option as USB or whatever, since just name (Fig. 5)
  2. it requires the location of the boot there (Fig. 6)
  3. I cannot find any other location than the current USB SSD (Fig. 7)

Fig. 5 Renaming as USB in Boot , Fig. 6 You cannot Enable Legacy Boot for some reason (Why?), Fig. 7-10 You cannot find right location for new boot option

enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

I cannot find a way to boot from USB.

2nd Iteration

I disable Secure Boot in Security > Boot. I enable CSM. I press Esc at the login. I get the list of items to boot from.

  • My test USB works
  • My Debian installer does not work so this confirms it is faulty.

Problem solved!

Hardware: Asus Zenbook UX303UA
OS: Ubuntu 16.04 64 bit Linux kernel 4.7
Grub: version 1

1 Answer 1

1

Plug in your USB drive

Turn on your pc

Enter UEFI through pressing ESC or F2

From the Boot tab Disable Fastboot

( Enable Launch CSM if you need to boot the Legacy mode)

Press F10 to save & exit

Press ESC or F2 again

In Boot tab your USB drive should be listed.

Change the order

Press F10 to save & exit

Your should now boot from the USB drive

Edit

You need to go to security tab, secure boot menu and choose disabled

2
  • Please, see the body for my iterations of your proposal. I cannot get USB listed. I cannot enable CSM for some reason. Commented Aug 31, 2016 at 16:06
  • 1
    go to security >> secure boot menu >> disabled
    – GAD3R
    Commented Aug 31, 2016 at 16:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .