4

Goal: synch a large number of large files (filesize>500MB) from one NAS (WD Mycloud) to another. rysnc is available on both. Both are connected via a Gigabit switch. NAS files can be moved with Windows Explorer at 40+MB/s, however the file metadata (dates) are changed to the current date. rsync runs at ~10-12MB/s.

I initially mounted source via CIFS, but I was informed this could be a bottleneck, so I ditched CIFS and tried to turn off compression:

rsync -aHXxvn --numeric-ids --delete --progress -e "ssh -T -c arcfour -o Compression=no -x" root@192.168.8.109:/shares/public/Data /shares/public/

This command originated from this article, which I think indicates the command would optimize SSH overhead

I didn't observe any speed increase. What test can be performed to diagnose the bottleneck preventing 40MB/s transfers?

  • 1
    the cpu in nas with ssl. – Ipor Sircer Aug 31 '16 at 5:14
  • @Ipor Sircer: Please clarify what I can do. CPU is armv7.1 – gatorback Aug 31 '16 at 5:48
  • You might be able to avoid the ssh overhead by using an rsync daemon (:: in the url) on the remote server. There's a large section in the man page. Your nas may propose it as a config option. – meuh Aug 31 '16 at 12:44
  • @meuh Is this what you are suggesting: jveweb.net/en/archives/2011/01/running-rsync-as-a-daemon.html ? – gatorback Aug 31 '16 at 15:19
  • Yes, but you can probably find more specific info for your nas. Alternatively, why not copy the files with windows, then do an rsync which just fixes the metadata. If you add --size-only then rsync wont even check the file contents, but simply update the timestamps. – meuh Aug 31 '16 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.