8

Background:

I am running the latest version of Kali Linux in a vmware workstation and I have a Cisco AE2500 wifi usb which works as a wifi adapter in Windows 10. Unfortunately, when i run the airmon-ng command, I receive

ls: cannot access '/sys/class/ieee80211/': No such file or directory.

I have tried every possible solution from 10+ forums and different google searches to fix this problem. Common solutions which fixed the problem for other individuals have yet been unsuccessful. Solutions include:

1) apt-get update && apt-get upgrade && apt-get dist-upgrade -y

2) The forum solution to download backports driver (4.4.2-1) and make defconfig-b43, compiled, installed, rebooted

3) The forum solution to download synaptic and then manually upgrade the bcm43xxx drivers

4) Airmon-ng forum

5) Vmware tools update

6) apt-get install kali-linux-wireless

7) installation of all wifi firmware drivers for both 80211, broadcom, atheros and intel chips.

and numerous others...

lsusb:

root@sandbox:~# lsusb
Bus 001 Device 003: ID 04e8:6863 Samsung Electronics Co., Ltd GT-I9500 [Galaxy S4] / GT-I9250 [Galaxy Nexus] (network tethering)
Bus 001 Device 002: ID 13b1:003a Linksys AE2500 802.11abgn Wireless Adapter [Broadcom BCM43236]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 004: ID 0e0f:0008 VMware, Inc. 
Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

iwconfig:

root@sandbox:~# iwconfig
usb0      no wireless extensions.

lo        no wireless extensions.

eth0      no wireless extensions.

But yet when I use airmon-ng:

root@sandbox:~# airmon-ng
ls: cannot access '/sys/class/ieee80211/': No such file or directory

PHY Interface   Driver      Chipset

(Please note airmon-ng check kill does nothing to modify this error message)

Please help... any suggestions are welcome.
Another line of questioning pertinent to fixing this problem is located here: https://unix.stackexchange.com/questions/306865/changing-a-driver-on-a-device-plugged-in-by-usb

1

If you are using a USB wifi adapter then do the following:

1) In the VirtualBox menu go to Devices > USB > select your wifi adapter

2) Wait as windows will install this virtualbox usb device and it will configure with your Kali Linux. At this point you will lose internet connection on the host machine (Windows in my case)

3) type in 'iwconfig' into the Linux terminal and you should see your wlan0 listed. success!

protected by Community Sep 16 '16 at 9:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.