3

Every time I power off my Dell XPS 13 9350 (running on Fedora 24), the shutdown hangs at 8 stop jobs. Seven of them are "A stop job is running for LVM PV..." and one of them is "A stop job is running for firewalld - dynamic firewall daemon" (which has a no limit at the time out time). Most of them are timed out after 1:30, two remain for like 4:30 after which the computer proceeds with shutdown. It seems like the luks containers cannot be properly closed, but I have some suspicion that it could be caused by the wifi driver too (for the Broadcom 4350 wireless card).

What is the cause of these stop jobs?

Any help would be appreciated!

  • Those processes almost certainly run as systemd services, search for all services related to LVM and the firewalld service. Then, check if the PID file (one of the parameters in the systemd service file) matches the actual process. – grochmal Aug 30 '16 at 20:22
1

It looks like you asked and answered this question on Reddit, so I will repost your solution here for others' benefit.

It is a problem occurring in Fedora since 21. Firewalld somehow calls the service 'cockpit' while it isn't installed (WARNING: FedoraServer: INVALID_SERVICE: cockpit). A solution to this is to disable the service. But since there isn't any .xml file in /usr/lib/firewalld/services/ you have to create one and then disable the service. More info on: https://bugzilla.redhat.com/show_bug.cgi?id=1171114.

WORKAROUND
----------
Create a file /usr/lib/firewalld/services/cockpit.xml containing the following (as extracted from cockpit-ws-0.96-1.fc23.x86_64.rpm):


<?xml version="1.0" encoding="utf-8"?>
<service>
  <!-- This is a firewalld service definition for Cockpit -->
  <short>Cockpit</short>
  <description>Cockpit lets you access and configure your server remotely.</description>
  <port protocol="tcp" port="9090"/>
</service>

Service "cockpit" is then also listed in the "Firewall Configuration" (firewall-config) application.
0

I tried chasing down the error with cockpit for a while because problem was still occurring when I had cockpit installed and the service running. What ultimately fixed this for me was following the advice here, which is to set CleanupOnExit=no in /etc/firewalld/firewalld.conf. Note that after changing that value and rebooting that first reboot still had the stop job running (the conf change hasn't taken effect), but the problem went away on the subsequent reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.