0

I have Centos installed.

In error logs I get the error

PHP Warning:  mysqli::mysqli(): Headers and client library minor version mismatch.

I have PHP 5.5 and mysql 5.6 installed.

It was suggested to use

sudo yum install php-mysqlnd

However, it gave error:

Processing Conflict: php55w-common-5.5.38-1.w7.x86_64 conflicts php-common < 5.5
Finished Dependency Resolution

UPDATE

Installed mysqlnd- mismatch problem is not solved.

0

The problem here is that the php-mysqlnd found in your repository is not 5.5. To install this package in the correct version, try running

sudo yum install php55w-mysqlnd
6
  • Installed mysqlnd, mismatch problem is not solved Aug 30 '16 at 8:19
  • Ah, this is due to the fact that php55w-mysql and php55w-mysqlnd both contain the same packages, so this will not resolve your issue. Taking a second look at this issue, it looks as if there are still some MySQL packages which haven't been updated. Run sudo yum update mysql*, see if that helps.
    – Hatclock
    Aug 30 '16 at 8:19
  • Sorry, prematurely hit enter. Updated the comment.
    – Hatclock
    Aug 30 '16 at 8:21
  • Gave No packages marked for update Aug 30 '16 at 8:22
  • Sorry, I forgot to restart the server. Thank you!! Aug 30 '16 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.