0

Im trying to reset a user password locally using the root account. The user is adam. Everything looks ok when I type in passwd adam using the root account. It prompts me to enter new password, enter the new password again.

Afterwards, When I putty in to the server and login in as adam using the new password, I get access denied. How do I resolve this issue?

  • Can you show us the user's /etc/passwd file entry? – Julie Pelletier Aug 29 '16 at 19:31
  • adam:!:214:1031:Adam:/home/adam:/usr/bin/ksh @JuliePelletier – unixHELP Aug 29 '16 at 19:38
  • Logon & rlogin set to true ? – Jeff Schaller Aug 29 '16 at 23:42
  • 1
    Account locked by virtue of unsuccessful login counts? – Jeff Schaller Aug 30 '16 at 0:23
1

The right fix for this situation is to reset the unsuccessful login counts for the user, not to disable a security feature.

Run:

chuser unsuccessful_login_count=0 adam

to clear the unsuccessful login counts for adam, and:

chuser account_locked=false adam

if needed (see if the account is locked with: lsuser -a account_locked adam).

| improve this answer | |
-4

Solved the issue. Add loginretries = 0 to /etc/security/users file

| improve this answer | |
  • 3
    That's like saying you solved your problem unlocking the front door by removing the lock. – Julie Pelletier Sep 2 '16 at 4:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.