0

Im trying to reset a user password locally using the root account. The user is adam. Everything looks ok when I type in passwd adam using the root account. It prompts me to enter new password, enter the new password again.

Afterwards, When I putty in to the server and login in as adam using the new password, I get access denied. How do I resolve this issue?

4
  • Can you show us the user's /etc/passwd file entry? Aug 29, 2016 at 19:31
  • adam:!:214:1031:Adam:/home/adam:/usr/bin/ksh @JuliePelletier
    – unixHELP
    Aug 29, 2016 at 19:38
  • Logon & rlogin set to true ?
    – Jeff Schaller
    Aug 29, 2016 at 23:42
  • 1
    Account locked by virtue of unsuccessful login counts?
    – Jeff Schaller
    Aug 30, 2016 at 0:23

2 Answers 2

3

The right fix for this situation is to reset the unsuccessful login counts for the user, not to disable a security feature.

Run:

chuser unsuccessful_login_count=0 adam

to clear the unsuccessful login counts for adam, and:

chuser account_locked=false adam

if needed (see if the account is locked with: lsuser -a account_locked adam).

-4

Solved the issue. Add loginretries = 0 to /etc/security/users file

1
  • 3
    That's like saying you solved your problem unlocking the front door by removing the lock. Sep 2, 2016 at 4:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .