6

A former coworker configured screen for me and I just found out I could change this, but I don't know what the setting is supposed to be and the man page is a little vague.

I've got this in my .screenrc

# no annoying audible bell, please
vbell on

I don't have a vbell msg defined, but the man page says the default vbell msg is "Wuff Wuff", I've never seen that particular message.

What I do see is a big annoying full screen flash every time I hit tab when a file doesn't exist (and this is starting to get on my nerves). It's better than a ding, but I'd rather have no indication than an annoying indication.

So, is there any way to completely disable the vbell without defacto enabling the real bell?

(Note, if you know this is just a putty question, I can close an ask on SuperUser, I saw the "bell" screen in the Putty setup which had some stuff that was already disabled for flashing - and it doesn't flash outside of screen)

2 Answers 2

12

You can do what you want in a terminal-independent way using just your .screenrc:

vbell on
vbell_msg ''
termcapinfo *  vb=:

The settings are:

  • first line (you already did this)
  • second line cancels the Wuff, Wuff!
  • third line sets the flash to an empty string

Note that the trailing colon (:) is needed for the termcap syntax used by screen.

2
  • 1
    That works, thanks! Wow, make sure you use a colon and not a semi-colon for that "vb=:" part or you'll wind up really confused.. Aug 30, 2016 at 11:32
  • 1
    As an extra note, for anyone interested, you can detach an existing screen after editing .screenrc for the right account and 'source /path/to/.screenrc' to apply this for existing screen sessions.
    – C-TZ
    Nov 15, 2019 at 8:46
6

To fully disable the bell, you first need to turn off the special bell treatment in screen. Having vbell on means the visual bell is on (opposite to the default), so a visual bell is emitted to the terminal. If the terminal does not support visual bells, the bell message is used. PuTTY never sees it as a true bell!

Set vbell off to turn off this behavior and use the normal bell instead. (See screen(1), search for vbell.)

Then, you need to configure your terminal emulator (PuTTY, in your case) to do what you want with the audible bell sequence. To do this, go into Change Settings, then Terminal > Bell, then select your preferred behavior.

PuTTY Configuration > Terminal > Bell

Select None to disable the bell entirely, Visual bell to flash the window, or one of the audible bell options to have the system make a sound.

Assuming your screen instance is configured correctly, you should be seeing the desired behavior after you click Apply.

1
  • 2
    This is the right approach. Although I found that screen defaulted to visual bell on, despite claims to the contrary in screen(1). Aug 24, 2017 at 7:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.