0

I have Kali Linux imaged onto a USB which I boot from and use live mode. It runs fine but it doesn't connect to a network.

When I use ifconfig it says I have a loopback address.

When I try to install it doesn't recognise a wireless network drive or wlan0.

wlan0 does not exist.

I used the command lspci

My Network Card is:

Broadcom Corporation BCM4352 802.11ac Rev03

When I run airmon-ng command it doesn't show any interfaces at all. I can't even see the option in the network manager to choose wireless connection.

  • Have you try ifconfig -a? – Romeo Ninov Aug 29 '16 at 13:15
2

I think you are missing drivers and firmware. Some Linux distro's do not include all drivers, specially not for wireless. I am not sure but I think the modules are provided in broadcom-sta-dkms

0

To confirm, you do have a eth0? If so. I highly suggest making sure your linux distro is pointed at the new(ish) Repo's https://docs.kali.org/general-use/kali-linux-sources-list-repositories and then make sure you can hit the internet through eth0 and run a full apt-get update. Reboot and try again. If that doesn't bring up the wireless NIC, there is a bigger issue. That broadcom NIC is pretty standard, so it should show up.

It is possible for OS images to get corrupted. Not common, but is a thing. I'd trouble shoot first with a lightweight distro like Lubuntu. Live boot that and see if wlan0 comes up. If so, try a fresh Kali image and copy the settings from lubuntu as they are pretty similar OS. If none of that works there is most likely a hardware issue. Also, don't forget a couple things:

Putting your wifi nic into Mon mode using airmon-ng and other things shuts off the network manager (most of time, depends on how you do it). So if it ever worked and you're doing some wifi cracking, that could be your problem. Also don't forget about:

iwconfig -a

Good luck, let us know if any of the above works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.