1

My primary display isn't working and I'm using a monitor. Unfortunately, Fedora 22 doesn't seem to pick up on this and acts as though I had two displays working simultaneously. As all system settings / the control panel, as well as several programs, launch on the primary display, I cannot get to some of the files I need (eg, Libre Calc), let alone adjust settings.

How can I do this via command line, or through some shortcut?

  • --off did the trick. Thanks. Want to post this as an answer so I can check it? – zadrozny Aug 28 '16 at 18:13
  • If you want to launch terminal and it is not visible, try using super+arrows to move window to other side – kokbira Apr 4 at 13:02
  • You also try disconnecting the problematic monitor and restarting the OS – kokbira Apr 4 at 13:03
  • Same for me occurred when I tried to use Cinnamon on Fedora for first time. Using the "trick" of turning off the problematic monitor, allowed me to start Cinnamon on "good" monitor. Then, I turned on problematic monitor, and it was recognizes. So I turned it the primary monitor again. – kokbira Apr 4 at 13:08
3

You could try to set your primary display with xrandr. First query your displays by just executing

xrandr

Then set the primary with e.g.

xrandr --output HDMI1 --primary

Or disable the other display with

xrandr --output eDP1 --off. 

Or you could write a /etc/X11/xorg.conf file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.