I've installed mysql through

$ sudo apt-get install mysql-server-core-5.1
$ sudo apt-get install mysql-client-core-5.1

This is my current conf file

And the service won't start, at first the socket and var folders did not exist, I created the mysql user and mysql group as system accounts and gave ownership and full control to the directories specified in the conf file.

the I tried running the mysqld as the mysql user:

$ sudo -u mysql mysqld 

And I get I get the following error

120201 13:52:58 [Note] Plugin 'FEDERATED' is disabled.
mysqld: Table 'mysql.plugin' doesn't exist
120201 13:52:58 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade     to create it.
120201 13:52:58  InnoDB: Initializing buffer pool, size = 8.0M
120201 13:52:58  InnoDB: Completed initialization of buffer pool
120201 13:52:58  InnoDB: Started; log sequence number 0 44233
120201 13:52:58 [ERROR] Fatal error: Can't open and lock privilege tables: Table   'mysql.host' doesn't exist

Also I'tried running it like this:

$ sudo service mysql start

Yields mysql: unrecognized service

Any suggestions are GREATLY appreciated.


Are you sure it's not already started? Check ps -ef | grep mysql. You should be able to use most Debian or Ubuntu guides on MySQL, since Mint is based on Ubuntu. You probably don't need to start the server yourself. Try restarting and see if it doesn't start automatically then.

Also, you probably need more than just the core. Why not just sudo apt-get install mysql-server?

  • I've checked that it's not running, but I'll install the mysql-server I thought that I only needed the core packages. – Tristian Feb 1 '12 at 23:41
  • Thanks that fixed the set-up. It just leaves me wondering why the apt-get didn't mention the mysql-server instead of the core packages. – Tristian Feb 1 '12 at 23:52

I had the same issue. But in my case, it was occurring because the ip address specified at line bind-address didn't match to my actual ip address.

bind-address =

I'm using Mint ver 14. so the line above was in the /etc/mysql/my.cnf

When I replaced with the correct ip address and restarted the service it started working:

sudo service mysql start

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.