4

I have a NAS with a custom OpenMediaVault image that was developed by a Russian, so the translation packages were originally in Russian. However, I deleted "ru" from sources.list, so that it draws from the main Debian repository. I've also changed the system locale, removing Russian from the list, and keeping only the English locale.

However, when I run apt-get update, it feeds me both the English and Russian translations.

Example:

Hit http://ftp.debian.org wheezy/main Translation-en
Hit http://ftp.debian.org wheezy/main Translation-ru

I don't know if it's actually downloading Russian translations, but because it's a NAS and I'm trying to keep OS files to a minimum, I don't want any extra and unnecessary files.

Is there a way to exclude these; and if so, how?

[Edit: I've gone to /etc to nano locale.gen, and the Russian locale is properly commented out, while only the English locale is called upon. Continuing to poke around...]

2

apt-get update will only load the package lists, to find out what's available: the actual upgrades are installed by apt-get upgrade.

The Translation-ru contains only the package descriptions in Russian, and is only about 420 KiB in size.

The package description translations are selected for download according to the following settings:

  • the LANG environment variable
  • the LC_MESSAGES environment variable (which can override the LANG)
  • or the APT::Acquire::Translation setting in /etc/apt/apt.conf or /etc/apt/apt.conf.d/* files.

The ru in sources.list only selects where you are downloading your packages from geographically, so you might now end up downloading updates from more distant servers than necessary.

0

I assume your NAS it's a WDMyCloud with Fox's OS images. For whoever stumbles on this question, the answer is

rm /var/lib/apt/lists/*Translation-ru

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy