I am trying to get a GEforce 970 running on linux mint, and I am stuck in software rendering mode after doing the following:

  1. adding the ppa from here
  2. sudo apt-get install nvidia-340
  3. reboot (after update)- no gui
  4. remove graphics card and edit grub default to include nomodeset
  5. reinsert graphica card
  6. now running in software rendering mode
  7. tried sudo apt-get install nvidia-current with no change.

Anybody have any ideas? I cant seem to find anything on the help forums I checked that works.

  • Please let me know why you downvoted this question so I can improve it
    – Rilcon42
    Aug 27 '16 at 4:00
  • Have a look at the arch minimal xorg config for nvidia apart from that you're likely to need Option "AccelMethod" "<something>". I have a Radeon in which I use glamor but I do not really know the NVIDIA options for AccelMethod.
    – grochmal
    Aug 27 '16 at 4:37

For a GTX 970, you should either use nouveau (the open source Nvidia driver), or the plain old proprietary nvidia module. Both tend to be pretty iffy (why I'm switching to Radeon graphics), so I would recommend finding which one works best for you.

As for getting out of software rendering mode, have you tried removing nomodeset from grub default and doing sudo grub-mkconfig -o /boot/grub/grub.cfg when /boot/grub/grub.cfg is your grub config file? Also make sure that you remove nvidia-340 and sudo modprobe nvidia when you have only that installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.