4

I'm having problems with automatically mounting my HDD using fstab entry.

In my fstab I added the following entry:

/dev/disk/by-uuid/CE20D46C20D45D51 /mnt/data1 auto default,exec,dev,suid 0 0

Whenever I try to remount it I get (from reading /proc/mounts):

/dev/sda1 /mnt/data1 fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096 0 0

The problem is that I need to have dev and exec enabled, but this is not working whatever options I add or remove from my fstab entry. Any ideas?

EDIT:

Linux: Linux Mint Mate 17.2 Rafaela

Kernel version: Linux version 3.16.0-38-generic

File System: fuseblk (ntfs)

dmesg doesn't show any messages after performing following commands:

sudo umount /dev/sda1
sudo mount -a

in /var/log/syslog I can find:

    Unmounting /dev/sda1 (Data1)
    Version 2013.1.13AR.1 external FUSE 29
    Mounted /dev/sda1 (Read-Write, label "Data1", NTFS 3.1)
    Cmdline options: rw
    Mount options: rw,allow_other,nonempty,relatime,fsname=/dev/sda1,blkdev,blksize=4096
    Ownership and permissions disabled, configuration type 7

EDIT2:

My full fstab file:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb8 during installation
UUID=fd6f2b28-add9-43d2-90e4-e8c619b881e1 /               ext4    errors=remount-ro 0       1
# /HOME was on /dev/sdb9 during installation
UUID=b85b696e-7306-4489-8370-c1b14562ab65 /home           ext4    defaults        0       2
# /boot/efi was on /dev/sdb1 during installation
UUID=0670-E6CA  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sdb10 during installation
UUID=dc53c42f-e148-4eb5-9e68-c70cbb2c03cd none            swap    sw              0       0
/dev/disk/by-uuid/CE20D46C20D45D51 /mnt/data1 auto users,exec,dev,suid 0 0
/dev/disk/by-uuid/2A6AD5C96AD59245 /mnt/data2 auto suid,exec,dev,nofail,x-gvfs-show 0 0

EDIT3:

Remounting it using:

mount -o remount,exec,dev /mnt/data1

Seems to work, but why doesn`t this work using fstab? I want this to happen automatically.

  • is there a virtualization or container or selinux ? after the mount, can you cut and post the last lines of dmesg and /var/log/messages ? – Massimo Aug 26 '16 at 8:06
  • 2
    please post also kernel, linux and ntfs-3g versions – Massimo Aug 26 '16 at 8:15
  • Posted some extra information I could find. – Dimitri Vernemmen Aug 26 '16 at 8:37
  • have you to fstab entries for the same disk or mount point ? – Massimo Aug 26 '16 at 9:00
  • 1
    Remounting using: mount -o remount,exec,dev /mnt/data1 seems to work, but it why can't I auto mount it this way? – Dimitri Vernemmen Aug 26 '16 at 12:06
1

Unfortunately this (mounting NTFS with suid and dev options from fstab) may not possible without modifying NTFS-3G or mount(8).

The problem is, the mount(8) program doesn't pass dev, suid and some other default options to related helper program, in this case /sbin/mount.ntfs; because they are considered default. These options should be effective and works if you are using the mount helper program directly: mount.ntfs -o exec,dev,suid /dev/disk/by-uuid/CE20D46C20D45D51 /mnt/data1

The workaround I recommended is to modify NTFS-3G to remove the default nodev and nosuid.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.